Function not found in API

Hey guys,
I’m trying to fetch data from the matomo API. I tried via React, I always get error 500 (strict-origin-when-cross-origin). So I tried using a proxy (cors-anywhere), still doesn’t work. With another proxy ( I am getting 429- too many requests. I guess with a website running in the browser that might not work requesting the matomo API?

With curl in the command line (Linux Distribution for Windows), I couldn’t reproduce the error, instead I am getting that the function cannot be found in the module API.

curl -X GET ‘…’

Matomo › Error
    <div class="header">
            <h1>An error occurred</h1>

    <div class="content"><h2>Action &#039;UsersFlow.getUsersFlowPretty&#039; not found in the module &#039;API&#039;</h2><p><a href="javascript:window.history.back();">Go Back</a> | <a href="index.php">Go to Matomo</a></p>  <ul>
                        <li><a rel="noreferrer noopener" target="_blank" href=""> homepage</a></li>
                        <li><a rel="noreferrer noopener" target="_blank" href="">Frequently Asked Questions</a></li>
                        <li><a rel="noreferrer noopener" target="_blank" href="">User Guides</a></li>
                        <li><a rel="noreferrer noopener" target="_blank" href="">Matomo Forums</a></li>
                        <li><a rel="noreferrer noopener" target="_blank" href="">Professional Support for Matomo</a></li>
                        </ul>    </div>

<div class="footer">
    <a href="index.php">&laquo; Back to Matomo</a>

Could it be that the version might be a problem? Afaik currently the version 4.16 is installed and the docs show for version 5.0.
Do you know what might be the issue?
Thanks in regard!