Fresh installation of Piwik not tracking visits


#1

Hi!

I’ve just installed piwik for my website www.hafdal.dk, which is running on Joomla 3. I have a plugin for the piwik script, which appears to be working (the code is visible in my website), but still Piwik is not tracking any visits.

This is not the first time I have installed Piwik, I have done it several times on other websites without any issues. This time, I have tried to use both my joomla database as well as a completely fresh database without success.

I did get some “cookies” errors during installation, but switched browsers and deleted the tables that had been created before the error so in the end I got a Piwik installation that looks okay, but is not registering any visits.

Any idea what could be wrong??

Thanks in advance
Rakel


#2

??


#3

I experience the same problem: installation showed the cookie error several times (although phpinfo shows session cookies activated) and I can access the dashboard etc. but it doesn’t log any activities…
when I look at the mysql database most tables are empty (for example all piwik_log_ - only piwik_log_action has a lot of entries…).

Now I tried it with several versions of the Tracking Code… also the image… but no records.

What to do? is there an older piwik version I can install?


(Matthieu Aubry) #4

I experience the same problem: installation showed the cookie error several times (although phpinfo shows session cookies activated) and I can access the dashboard etc. but it doesn’t log any activities…

Please try to re-install Piwik as follows

  1. delete config.ini.php file
  2. edit config/global.ini.php file and set line 216:

session_save_handler = dbtable

  1. install piwik

-> does it solve your problems afterwards maybe?


#5

Thank you for your help, but - No, unfortunately it did not work…

still the cookie error, which can be overridden by going over it several times…

then again no tracking: piwik_log_action and piwik_option are full with data entries, but most other tables are empty.

could there be a permission-problem while writing to the tables?


(Matthieu Aubry) #6

Maybe you are using the “adblock” extension in your browser?


#7

I have same problem, fresh installation do not track any visits, table visits log is empty, with old 1.12 installation everything works fine?


#8

piwik_log_action have data
piwik_log_visit is empty
tried 2) edit config/global.ini.php file and set line 216: no success


(Matthieu Aubry) #9

please comment if you can on this ticket: #5005 Install with errors, not tracking
Install with errors, not tracking · Issue #5005 · matomo-org/matomo · GitHub - I think you experience same problem

we will try to get it fixed ASAP


#10

I see this post is a couple of months old, but there is no resolve posted.

I have the same issue.

I actually upgraded to 2.4.1 and the system shows no updates available.
Yet, I have NO tracking information. It’s been a couple of weeks that the site was “supposed” to be tracking.

I’ve checked the tracking code and can’t see anywhere that would indicate a problem.

I’m using the “plugin” within Joomla for Piwik, and that’s not working.
The code is there, but I get no stats.


(Matthieu Aubry) #11

see FAQ: Piwik doesn't track any visits and pages, and shows "There is no data for this report" in all reports. - Analytics Platform - Matomo