Fresh install - no visitor tracking

Hi there,
I installed matambo 3.8.1 yesterday and visited the two pages, but nothing has been tracked yet.
I checked the browser console, switched off all my AdBlockers (uBlock, Privacy Badger, Firefox built-in). The settings have been stored in the DB, but besides that it looks rather empty.

tracked sites:

matambo installation:

Thanks for any help!


For me everyting seems to be working fine.

Can you please check if my page views appear in Matomo?

Also please check if you haven’t set the date selector to “yesterday”

1 Like

Lukas, thanks for checking. I can now see a few entries for, for it still says (German version, happy to translate)

I opened the homepage in Firefox, Safari and Opera, but nothing shows in the real time visitors counter widget. The request to matomo.php seems alright, though. Any idea?



It is also looking fine for me there (and the request to matomo.php also looks fine).

Make sure you don’t have Do Not Track enabled in these browsers, because Matomo respects this header.

1 Like

Good point, but still nothing. It was enabled in Opera and disabled in Safari. If you have just visited the site, it hasn’t been recorded either. I set the time frame to February.

Interestingly the system recorded one visit for “michaelscheiner de” in the meantime, but it came from some old tracking code on another domain “” to the same analytics domain for a previous Piwik installation.

Hi Lukas,

I checked again today for the whole year (which are still just ~7days) and have the following findings within matombo:

  1. under “” (idSite 1) I got all entries for the domain as well as all entries for michaelscheiner(dot)de
  2. under “ 2) I still only got the one entry for (I will next create a separate domain setup for it.)

Any idea what’s going on?

Thanks for your help again,


I have just checked again and found the error:

If you check the tracking code, you see _paq.push(['setSiteId', '1']); on both of them. But you need to set the site id to the site where you want the data to be tracked into.

So on edit the tracking code to site id 2.

1 Like

Should have seen this myself :confused: must have been a copy/paste issue while adding one code after the other.
Thanks a lot for your time & effort Lukas! :smiley: :raised_hands:

1 Like