Force tracking without cookies and Disable cookies not working

Hi there.

I’ve implemeted Matomo on our WordPress site and am using Tag Manager. I’ve selected Disable cookies in the Matomo configuration variable and have selected Force tracking without cookies under Administration → Privacy → Anonymize data.

However, when a tag fires, it sets a _pk_id cookie.

Any ideas?

Thanks

John

Hi,

Could you maybe send me a link to your website as a direct message so I can take a closer look.

Also make sure to check if you have released the Tag Container after updating the setting.

Hi Lukas, thanks for the reply.

I’ve sent you a link to our test website via DM.

If you go to the Kontakt section at near the bottom of the page and click either the email or phone number, or submit the form, you’ll see what I’m talking about.

Thanks


Screenshot 2021-07-20 125612

Hi,

Honestly I don’t see the issue.

When I click on e.g. the email address I see the tracking request to Matomo, but no Cookie is set on the whole site.

Is this cookie maybe still there from before you disabled them in Matomo?
Can you test this in a fresh browser maybe (e.g. using something like chromium --temp-profile)

Hi Lukas.

I tried testing in Chrome incognito and with a temp profile, and Microsoft Edge and keep getting the same _pk_id cookie. Firefox was good though.

I’ve been deleting the cookies, so don’t think it’s there from before.

Any other suggestions?

Thanks

@SplendidInternet I’ve just tried to reproduce it in Chrome and no cookie was set for me either. Possible that it’s maybe a race condition or so. Are you logged in when this happens or logged out? As you are using incognito I’m assuming you are logged out but just wanted to double check.

Hi Thomas

I tried reproducing the problem on a collegue’s computer and I couldn’t see the cookie either.

On my machine I’m logged out and in cognito. Another collegue is also seeing the cookie the same as me on his machine. Do you have any ideas as to why this would be?

Thanks

John

@Lukas @thomas_matomo

I’ve just recorded a quick video showing the issue. Hopefully this can clarify what we’re experiencing.

https://share.vidyard.com/watch/mXorL4xfgT466PMzB1z71k?

Thanks

John

Interesting. Not sure how this would happen. And I still have trouble to reproduce it that way even when clicking on “Certificate”. It never creates a cookie for me.

I wonder if this maybe only happens on your prelive site as we can’t test there? Does it happen for you on your actual site?

If there’s a possibility that we can access prelive feel free to send us basic auth details to wordpress@matomo.org

Hi @thomas_matomo

I’ve sent those details through to the email you provided.

It’s not just the prelive site, it happens on our live site also.

It happens on two other of my collegues computers. Could this be some kind of cache stored on our copmuters? The three of us have tested these elements before, so maybe something is stored. I tested it on another collegue’s computer and couldn’t recreate the problem. I flushed the DNS cache, but that didn’t do anything.

The problem is on Chrome. Firefox seems to be ok.

Thanks

John

Thanks for this @SplendidInternet . I can now reproduce this and created this issue: https://github.com/matomo-org/matomo/issues/17892 I would assume that we look into this soonish. I could recreate it actually after clicking on the phone number.

There is basically a cookie created and then deleted again right away. And the cookie information in the SSL certificate popup is outdated. It is showing the cookie when it’s actually deleted. Nonetheless we shouldn’t create it in the first place.

@thomas_matomo

Awesome, that’s great to hear.

I look foward to hearing back about this.

Thanks

John