Force tracking without cookies and Disable cookies not working

Hi there.

I’ve implemeted Matomo on our WordPress site and am using Tag Manager. I’ve selected Disable cookies in the Matomo configuration variable and have selected Force tracking without cookies under Administration → Privacy → Anonymize data.

However, when a tag fires, it sets a _pk_id cookie.

Any ideas?

Thanks

John

Hi,

Could you maybe send me a link to your website as a direct message so I can take a closer look.

Also make sure to check if you have released the Tag Container after updating the setting.

Hi Lukas, thanks for the reply.

I’ve sent you a link to our test website via DM.

If you go to the Kontakt section at near the bottom of the page and click either the email or phone number, or submit the form, you’ll see what I’m talking about.

Thanks


Screenshot 2021-07-20 125612

Hi,

Honestly I don’t see the issue.

When I click on e.g. the email address I see the tracking request to Matomo, but no Cookie is set on the whole site.

Is this cookie maybe still there from before you disabled them in Matomo?
Can you test this in a fresh browser maybe (e.g. using something like chromium --temp-profile)

Hi Lukas.

I tried testing in Chrome incognito and with a temp profile, and Microsoft Edge and keep getting the same _pk_id cookie. Firefox was good though.

I’ve been deleting the cookies, so don’t think it’s there from before.

Any other suggestions?

Thanks