::ffff: in IP address


#1

Hello,

We just moved last week from Apache to Nginx as web server for piwik and since then every IP addreses gets displayed with ::ffff: in front of it (for example: ::ffff:192.168.10.20). I guess this the IPv6 representation but we would like to avoid this and get the normal IP address back as our excluding doesn’t work anymore.

How do we do that? Any ideas?

Many thanks in advance for the help.


(vipsoft) #2

The sites manager accepts ipv6 addresses. edit these to include the prefix.

Or you could try changing your nginx config, listen 80 vs listen [::]:80.


(Matthieu Aubry) #3

Anthon, maybe we could update the Inline help message and show the ipv6 type addresses when the server is configured this way?


#4

Thanks, I have now followed your advice and modified the listen parameter on my nginx configuration in order to avoid this annoying ipv6 formatting and having to modify all my excludes.

Cheers