Few errors while loading data on a new installation


#1

Hello everyone,

I’ve been this weekend and until today trying to find information about the errors that I’m getting. It seems that some people has reported similar errors before, but none of them (as far as I can see) has been solved so far. The post I’ve found with the best description is 301 Moved Permanently however I don’t get the same errors Knut describes latter on, I have not problems at all trying to log in.
So, let’s describe my problem which it happens as soon as someone visits the tracked site (i.e., while the database is empty everything looks normal, and just ‘no data’ is shown).

The error messages I get are, as described by Knut Torgersen:
[ol]
[li] “Oops… problem during the request, please try again” in the top center area (orange color)
[/li][li] “Loading widget, please wait” on all widgets, except the world map and Visitors in Real Time
[/li][li] World map: “error while loading data (SecurityError)”
[/li][/ol]

What have I tried? I’ve tried to install it in different directories, using different databases names, I’ve even tried the latest SVN version… and always the same problems appear. Once there’s something on the database the page try to reach something and shows the errors listed above.

What have I found? As I said, there’s nothing that I can find on the logs (apache, and mysql) related with this. However, I’ve found using Firebug on Firefox, that some modules get a common error:

  • 502 Bad Gateway *
    The modules from which I get those errors are:
    Module Action
    VisitsSummary getEvolutionGraph
    VisitorInterest getNumberOfVisitsPerVisitDuration
    Referers getKeywords
    getWebsites
    getSearchEngines
    UserSettings getBrowser
    VisitTime getVisitInformationPerServerTime
    API UserCountry getCountry

The only widget that looks fine is the ‘Visitors in Real Time’ (and the visitor Log under the Visitors tab).

I’ve tried to access to the piwik page also from different machines (including from the server itself) and the same is shown everywhere.

The server is a:
OS X Server 10.5 (with the latest updates) with
MySql 5.0.92
php 5.3.0 from www.entropy.ch (includes pdo and pdo_mysql (Client API version: mysqlnd 5.0.5-dev - 081106 - $Revision: 1.3.2.27 $))
and all third party plugins are disabled and the proxy is configured properly (the Feedburner statistics widget does not work otherwise).

Any ideas of why is this happening? Anyone that has reported similar errors on the previous posts has got a solution?
Mike (gnomepark): 301 Moved Permanently
Knut Torgersen and Andreas: 301 Moved Permanently

Thanks!
David


(Matthieu Aubry) #2
  • 502 Bad Gateway *

Probably you will find an error in your web server error log?


#3

Thanks a million, Matt!!

You are right!!! there was an error (or thousands of them) on the error log file. I’d looked on the logs that the ‘admin server’ tool has, nothing there, I also had looked on the usual directories (/var/log/…) where they should be, and there were just old files. Finally, googling more and more for logs location on this kind of server, I’ve found that httpd -V http://macdevcenter.com/mac/2001/12/14/apache_two.html shows where they should be…

-D DEFAULT_ERRORLOG=“logs/error_log”

but… where that logs directory is? I don’t know. But since others variables were pointing to files inside a /private/ directory I looked there and finally found the real error log file in:

/private/var/log/apache2/error_log

The errors that I was having were the common: “Segmentation fault Error” which is mentioned on the FAQ Troubleshooting - Analytics Platform - Matomo

Changing pdo_mysql to mysqli on the adapter (config/config.ini.php) did not the trick, but almost.
To make it work I just had to edit my php.ini with this line:
mysqli.default_socket = /var/mysql/mysql.sock

And now it works perfectly!!!

Thanks for insist on that report on the logs!! now it works and also I’ve learnt where the real logs are!!!


(Matthieu Aubry) #4

Thanks for following up, glad it worked!!


#5

I am having the exact same problem. I tried what dvdgc suggested and it just made my server give me an error page saying “The connection has been reset” Does anyone have any other suggestions on how I can fix this problem?


#6

FYI I solved this by downgrading from PHP 5.3.0 to PHP 5.2.9


#7

http://www.infoocean.info/avatar2.jpgProbably you will find an error in your web server error log?


#8

Halosmyth, when I solved the problem I didn’t need to downgrade anything, just changed what I mentioned before. I cannot check the configuration I had because the server died and I have not had time to built everything again as it was, piwik is still on the TODO list.


#9

I did find an error in the server log and researching it I was found to move some DLL files from my php folder to the windows system folder. But those DLL files did not exist for my in the php folder so that did not work.