Fehlermeldung bei ANmeldung


#1

Nach einer erfolgreichen Installation von piwik erhalte ich bei der Anmeldung die Fehlermeldung:

“Fehler: Form security failed. Please reload the form and check that your cookies are enabled. If you use a proxy server, you must configure Piwik to accept the proxy header that forwards the Host header.”

Dies geschieht sowohl mit dem Browser Firefox 4.0 RC als auch Chrome.

Tatsächlich sind die Cookies aktiviert. Einen Proxy-Server gibt es nicht.

Die gleiche Fehlermeldung erscheint, wenn man nach Anklicken auf ‘Passwort verloren’ sich ein neues Passwort an die angegebene bzw. zuvor bei der Installation registrierte E-Mail-Adresse senden lassen will.

Was muss ich für eine erfolgreiche Anmeldung tun?


#2

Hallo,

ich bekomme die gleiche Fehlermeldung.
Allerdings erhalte ich diese nur, wenn ich mit meinem Client PC über einen Proxy Server die Seite aufrufe. Ohne Proxy geht es problemlos. Die Konfiguration über die config.ini.php hat nichts gebracht.

Edit: habe es mit Firefox und IE9 getestet.

Ideen?

Danke und Gruß
JHL


#3

In unserem konkreten Fall trat der Fehler nicht mehr auf, nachdem wir mit unserer Internetseite innerhalb des Providers (Strato AG) auf eine neue Plattform umzogen, die augenscheinlich mit aktuellerer Software arbeitet.


#4

Hi,

das Problem lässt sich auf den IE eingrenzen. Mit Firefox geht es problemlos (mit und ohne Proxy).
Bei IE8 und IE9 ist ein einloggen nicht möglich. Egal ob mit oder ohne Proxy-Server.

Fehlermeldung:

Daher denke ich, dass es nicht an der Piwik konfiguration liegt.


#5

[quote=jhl]
Hi,

das Problem lässt sich auf den IE eingrenzen. Mit Firefox geht es problemlos (mit und ohne Proxy).
Bei IE8 und IE9 ist ein einloggen nicht möglich. Egal ob mit oder ohne Proxy-Server.

Daher denke ich, dass es nicht an der Piwik konfiguration liegt.[/quote]

Das ist kein IE Problem, sondern tritt bei mir mit allen Browsern auf (IE 9, Firefox 4, Chrome 11).

In unserer Umgebung vermute ich ein Problem mit einem transparenten Proxy (Firewall mit NAT und Loadbalancing). Bei direktem Zugriff auf die Apaches funktionierts auch bei mir.

Gruß,

jpr


#6

Ich habe auch das beschriebene Problem.

[quote=19feet]
In unserem konkreten Fall trat der Fehler nicht mehr auf, nachdem wir mit unserer Internetseite innerhalb des Providers (Strato AG) auf eine neue Plattform umzogen, die augenscheinlich mit aktuellerer Software arbeitet.[/quote]

Klingt interessant. Ich bin auch bei strato. Ich habe mal ein wenig rumgeguckt, was bei Strato denn nicht funktionieren könnte. Es ist so, dass man aus der $_SERVER variable mit PHP keine “referrer” auslesen kann. Villeicht hat es damit etwas zu tun?

[quote=jhl]
Hi,

das Problem lässt sich auf den IE eingrenzen. Mit Firefox geht es problemlos (mit und ohne Proxy).
Bei IE8 und IE9 ist ein einloggen nicht möglich. Egal ob mit oder ohne Proxy-Server.

Daher denke ich, dass es nicht an der Piwik konfiguration liegt.[/quote]

Das ist bei mir nicht der Fall. Bei mir ist es egal, welchen Browser ich verwende. Auch welches Betriebssystem für die Anmeldung genutzt wird war bei mir nicht relevant.
Durch Googlen bin ich dann noch auf diesen Blogeintrag gestoßen:

Das unterstützt ja meine Vermutung. Trotzdem weiß ich nicht weiter.

Weiß jeman eine Lösung?


#7

Ich habe das gleiche Problem das ich mich nicht Anmelden kann mit Safari.
Merkwürdigerweise kann ich mich mit meinem Mobiltelefon und der App die Besucherstatistik anschauen, aber wenn ich den Browser nehme geht auch nichts.

Was muss ich konkret ändern damit ich mich Einloggen kann? Muss mein Provider was ändern?


#8

Habe ebenfalls dieses Problem und bin auch bei der Strato AG.
Habe versucht, die $_SERVER-Variablen zu manipulieren, doch das brachte keinen Erfolg :/.


#9

das liegt wohl an irgendein setting bei Strato.
habe es auf mein homeserver erfolgreich installiert.
was ist wohl anders bei Strato ?


#10

Ich bin bei einem anderen Anbieter und es geht nicht, also dann ist es kein Problem von Strato


#11

[quote=Thur]
Ich bin bei einem anderen Anbieter und es geht nicht, also dann ist es kein Problem von Strato[/quote]

sorry, hätte ich besser gesagt vom “Provider”, bei mir zufällig Strato.
denn warum funktioniert es OK wenn auf mein einfachen e-Trayz homeserver installiert.
was ist denn da anders im (PHP ?) setup / environment ?


#12

[quote=kaasneef]

[quote=Thur]
Ich bin bei einem anderen Anbieter und es geht nicht, also dann ist es kein Problem von Strato[/quote]

sorry, hätte ich besser gesagt vom “Provider”, bei mir zufällig Strato.
denn warum funktioniert es OK wenn auf mein einfachen e-Trayz homeserver installiert.
was ist denn da anders im (PHP ?) setup / environment ?[/quote]

Okay… ich vermute es liegt am fehlenden Support für die Referer-URL in der $_SERVER Variable.
Folgendes ist bei mir (Strato) nicht möglich, da der Eintrag ‘HTTP_REFERER’ gar nicht existiert.


$referer = $_SERVER['HTTP_REFERER'];
// $referer enthält nichts.


#13

Ich habe herausgefunden, dass man die Referer-URL per PHP einschalten kann. Einfach folgenden Code in eine PHP Datei kopieren und die Datei ausführen.


echo ini_get('session.referer_check');

if (!ini_get('session.referer_check')) {
    ini_set('session.referer_check', 1);
}

echo ini_get('session.referer_check');

Das löst allerdings nicht das Problem. Darum habe ich im Englischen Forum einen Thread gemacht:
http://forum.piwik.org/read.php?2,75338


(vipsoft) #14

Please don’t set it to 1. PHP expects a substring to match in the Http-Referer header to validate the session ID. If the substring isn’t found, PHP invalidates the session, resulting in the loss of the token used to protect against CSRF attack.

If you can confirm that this works, then I’ll add it to core/Session.php:


ini_set('session.referer_check', '');


#15

Habe beim Strato einen Upgrade zum kostenfreien “SpeedPlus” beantragt, der mir seitens des Support-Teams vorgeschlagen wurde. Nun läuft alles :slight_smile:


(vipsoft) #16

Note: discussion is split between here and this thread 301 Moved Permanently


#17

I had the same problem. In my case it worked again after I commmented
session_save_handler = "dbtable"
so it saves in filesystem (default) again. After that I could login again without problems.


#18

After trying to find the error (I had to set session_save_handler = “dbtable” because otherwise Piwik is really slow), I found a workaround:
Comment the lines 109 - 112 of core/Session.php (Piwik 2.0.3):
/$saveHandler = new DbTable($config);
if ($saveHandler) {
self::setSaveHandler($saveHandler);
}
/

Then the login works again. I think there is a bug in validation. Should be something for the bugtracker.