Fatal error: Out of memory (allocated 7602176) (tried to allocate 4294967294 bytes) in piwik/libs/Zend/Db/Statement/Mysqli.php on line 255


#1

hello:
I always get this error:
Fatal error: Out of memory (allocated 7602176) (tried to allocate 4294967294 bytes) in piwik/libs/Zend/Db/Statement/Mysqli.php on line 255

And my environment is solaris 8+apache 2.2.17+php-5.3.6+mysql-5.0.67.

And i change the php.ini :memory_limit = 2048M.
and it show
Fatal error: Out of memory (allocated 7602176) (tried to allocate 4294967294 bytes) in piwik/libs/Zend/Db/Statement/Mysqli.php on line 255

too.

can someone help me. Thank you very much!!


#2

when i edit Mysqlli.php in piwik/libs/Zend/Db/Statement/Mysqli.php
$this->_stmt->store_result();
// bind to the result variables
echo memory_get_usage()."
";

call_user_func_array(
array($this->_stmt, ‘bind_result’),
$this->_values
);

It show this :

6883776
7456888
Fatal error: Out of memory (allocated 7602176) (tried to allocate 4294967294 bytes) in /udir/webadm/rdr/piwik/libs/Zend/Db/Statement/Mysqli.php on line 256

Can someone help me . Thank you very much!!!


(vipsoft) #3

Coincidentally, 2^32 = 4294967296 (ie 4 GB )

lt looks like a PHP bug. (I’m guessing a signed -2 was cast to unsigned).


(vipsoft) #4

If you report this bug to the PHP folks, they’ll want to know if you’re using libmysql or mysqlnd. This is the Client API version shown in your phpinfo() for the mysqli extension.


#5

thanks Anthon , I will change the version of php, and try again.


(vipsoft) #6

5.3.6 is the latest (and supposed, greatest).

Perhaps recompile php from scratch with other options?


#7

Hi,

I am getting exact same error … were you able to fix it ??? If so whats the solution.

Thanks in advance.

–Kumaresh