Fatal error: Cannot redeclare class Spyc in


#1

Hello

Have done a search and tried to find more info on this, bit surprised as not finding anything useful.

I am using PIWIK to track hits on my Joomla install site.

I got this error when I clicked to auto install an update for PIWIK. Everything has been working fine up to now.

I was running 2.1.0 and the site requested upgrade to 2.11.2

Fatal error: Cannot redeclare class Spyc in /home/USERNAMEHERE/SITEHERE/analytics/libs/spyc.php on line 57o
Anyone know a fix for this?
I did read one post which appeared to be relevant, and deleted the config file in the PIWIK folder (the advice said it would recompile and try to reinstall) but still getting the same err.
Thank you


(Matthieu Aubry) #2

Hi there,

to solve this issue, delete the file /libs/spyc.php from your piwik


#3

Thanks for response, tried that

Fatal error: require_once(): Failed opening required ‘/home/[user]/[domain]/analytics/libs/spyc.php’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/[user]/[domain]/analytics/plugins/DevicesDetection/UserAgentParserEnhanced/UserAgentParserEnhanced.php on line 10

error as above :frowning:


(Matthieu Aubry) #4

Delete all piwik files,

then use 2.12.0 RC I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo

should work!