Fatal error after upgrade to 3.5.1


#1

Hi Friends,
I’ve just upgraded to 3.5.1 (from 2.5.something), mostly successfully. At first, I had a fatal error:

Blockquote The following error just broke Matomo (v3.5.1):
Call to undefined method Piwik\Menu\MenuAdmin::add()
in
/home/brynn/public_html/stats/plugins/ReferrersManager/Menu.php line 21

I tried the first 2 easy options, refresh the page and restart the server, without success. Reading on, it gave me the option to deactivate that plugin, and that did bring back my dashboard. So then I started breathing again, haha.

Anyway, when I looked at the Plugins page, it shows there’s an update for that plugin. So here’s my question. Is it possible that simply updating that plugin might fix the problem? Or should I proceed with reporting the error (which I assume would mean ultimately fixing line 21).

Thank you very much :slightly_smiling_face:


(Fabian Dellwing) #2

Mostlikely the update will fix this issue.


#3

Ok, I’ll give it a try.

Thanks!


#4

Good news! The update went through, I’ve reactivated it, and no fatal error showed up.

Thank you very much!