Failing miserably installing Matomo on DigitalOcean Droplet

So i needed a completely external resource from where to run my Matomo stats and I chose DigitalOcean since they have a reasonable price/service level and frankly, I wanted to get up to speed fast and easy.

Checking around a bit I also see they have tutorials for installation on Ubuntu 20 which I chose as OS for the droplet, so I went for Ubunto 22 in the droplet, stumbled over a small certbot issue that was solved but despite getting through to the interface to configure my Matomo, it just wont hold. DB goes away and other issues ends my attempt. I have now tried 6-7 different times each time finding small issues with the tutorials available so I would like someone with greater knowledge to go through that and make a revision.

This is the tutorial:

When starting to read it implies we have Ubuntu and Docker installed, Fine, we do that. However, when getting to apt update, it does not say apt upgrade, so I did not do upgrade. I follow it TO THE LETTER since I am not very good with this cli shit. Also when getting to the docker-compose part, nothing happens since no where I have installed docker-compose. It is not stated anywhere that I can see.

So could anyone please gave a look at the DO writings and help me out, been at it on and off for a week and getting really frustrated with it.

Am I to believe no one is using DigitalOcean or had issues following the guide?

So I actually was able to sort it out.

The key thing was to ignore anything security related as in using later versions of Ubuntu and Certificate handling, and do exactly, using the exact versions, as in the Guide.

I also was a bit to lean on the RAM, I used a basic low performing droplet with 512MB of RAM and that was probably also adding to the issues. After upgrading the droplet to 1GB of RAM, and a bit more CPU, still 1 core though, the result was success. System check is A OK but I guess I still need to address cron and geolocation.

So why do I keep posting when no one bothered to reply?

So someone else may see this and benefit from it.

Remaining woes is what might happen if I upgrade Ubuntu 20 to Ubuntu 22. But I can make a snapshot and try.

1 Like

Maybe there is not so much users on DigitalOcean… :confused:

I currently am deployed on Digital Ocean for some projects.
I am not overly skilled and everything worked by the end of the morning working on it. I admit I did not use the D.O. tutorial though. I used the official one at Matomo: On Premise Guides

For people that prefer videos for setting up on Matomo On Premise there is a short video here :
And a much longer Matomocamp video here, by Boris Budini:

1 Like

I did read the on premises guide, but each host has slightly different configuration. Different admin interfaces and different parameters. One has to read that as a general approach.
Thanks for that, but I am no fan of vid tuts… Tend to ignore them due to several reasons.

1 Like

I forgot to mention that the upgrade to Ub 22 went well

1 Like

Oh excellent! Thank you for posting the update.

This is still running and have survived all, and I mean all, the “apt upgrades” I have done to this day. And I did all available.

There are two remaining concerns I probably should look in to

  1. Cron setup on the host.
  2. Certificate storage is deprecated.

I shall look for solutions to this eventually…