Failed to load HTML file: Error 403


(Dany Stastka) #1

I have following error Message on my Dashboard:

Failed to load HTML file:
Please check your server configuration. You may want to whitelist “*.html” files from the “plugins” directory. The HTTP status code is 403 for URL “plugins/CoreHome/angularjs/reporting-page/reportingpage.directive.html”

I can successfull surf to /plugins/MultiSites/angularjs/dashboard/dashboard.directive.html (Sample FAQ) and if i allow Browse Directory I see no Error Message but List of Files/Folders from /plugins/CoreHome/angularjs/

My Configuration:
Windows Server 2016, Windows 10 (1803), php 7.2, Matomo 3.5.0, Firefox, Chrome


(Fabian Dellwing) #2

Well, something is blocking the call (403 == not allowed), you should take a look at your error log (the one from the websserver) to get more informations.


(Dany Stastka) #3

Hi Fabian

I found the Problem in the Logs. I have some RewriteRules with Helicon ISAPI Rewrite who rewrite URL.
Dany


(Fabian Dellwing) #4

We are not using Windows server, but my guess would be that some security option is either blocking page or cmd variable.

You can test this by calling any site on the server you know works (e.g. https://matomo.dev/index.php).


(Dany Stastka) #5

Hi Fabian
I found the reason. I have some RewriteRules if contains URL word “page”. I change the Rule and matomo have no Errors.

Dany