Export of more than 100 rows does not work in 3.01

After upgrading to 3.01 I can not export more than 100 rows to TSV (Excel) format. I make the report flat and I choose 500 rows on the cog wheel but when I export to TSV I only get 100 rows.
I have tried to add &filter_limit=500 and &flat=-1 but nothing happens. Are these parameters of no use in the new version?
Can somebody give me some workaround tips??

Grateful for all help!
Best regards,

1 Like

Hi there,

I think this is a bug. But you can circumvent it by setting “API_datatable_default_limit” to “-1”.

Piwik explanation of that value: “default number of rows returned in API responses this value is overwritten by the ‘# Rows to display’ selector. if set to -1, a click on ‘Export as’ will export all rows independently of the current ‘# Rows to display’.”

Thanx for the tip.
I also found information that you can use filter_limit=-1, see:
But when I put it into my url (see below) it does not work. I only get 100 rows anyway. Do you have any thoughts and tips about that?


Grateful for your help!

Forgot the link: Reporting API Reference: API Reference - Piwik Analytics - Developer Docs - v3
And there you find information about filter_limit.