Everything below date and about piwik blank on 1.6


#1

I have two piwik servers… one linux and one windows… they share a database… the linux one works fine… the windows on is blank below the data drop down and about piwik area…

firebug shows this error on the windows box… the linux side has no error

$(".nav").superfish is not a function
https://angelstats.sln.suny.edu/piwik/index.php?module=Proxy&action=getJs&cb=94930b8a239d73a13b5d80d94d15639d
Line 2181


(Matthieu Aubry) #2

Please test with Piwik 1.7? 301 Moved Permanently


#3

I applied the beta and I still have the same issue…

I do get a new javascript error now :


$("#sitesSelectionSearch .custom_select_block").on is not a function
https://angelstats.sln.suny.edu/piwik/index.php?module=CoreHome&action=index&date=today&period=day&idSite=7
Line 204

along with


$(".nav").superfish is not a function
https://angelstats.sln.suny.edu/piwik/plugins/CoreHome/templates/menu.js?cb=cc4aaaa646a989a5f18480494aa18641
Line 63


(vipsoft) #4

Clear your browser cache, and remove the files under tmp/assets/*


#5

thanks… I cleared my browser cache and removed the files under tmp/assets and still have the same issue…


#6

bump… not sure what to do next to debug this…


(Matthieu Aubry) #7

Please try with the latest beta 8, it should work. If not, check your error logs.


#8

ok… I put beta 8 on the server… cleared the all the temp directories… disabled browser cache… and I still get the same error…

when I look at the page source I see :

Oops… problem during the request, please try again.

I have updated php from 5.3.3 to 5.3.9 with the same error…

when I turned on logging to sterr in php this is all I got

Faulting application php.exe, version 5.3.3.0, faulting module php5.dll, version 5.3.3.0, fault address 0x0000af4b.

So I know php is blowing up on piwik… but the phpinfo page works… as do the piwik settings pages… just the dashboard blows up

I have no idea if it will help but here’s my php.info : http://angelstats.sln.suny.edu/piwik/p.php


(Matthieu Aubry) #9

If you look with Firebug, you will see the request that fails to load. Is there an error there?


#10

thats the thing… firebug’s net all shows everything being status code 200… good to go… the only error I get are the two javascript errors above… on the working linux piwik server it just has a longer list of things being grabbed with status code 200 and no javascript errors…

I can get a wireshark dump of this if it would help…

thanks


(Matthieu Aubry) #11

Update your PHP to the latest version and try again?


#12

ok… I will give that a try but I have already done one upgrade and the problem persisted