Event Value is not being populated

Hi Everyone,

I have set up Event Category, Action and Values for the Matomo Events that I have set up in Tag Manager. I can see Event Category and Action in the Report, however, the Event Value is blank (for all the tags). I have passed parameters such as {{ClickDestinationUrl}} , {{PagePath}}
in Event Value, but that’s not being captured. Can someone tell me why is it so, and what can I do to fix this?

Hi Ratna,

I don’t know why event value does not work even though you have passed the destination url and page path but I was hoping that you would help me set up events in general by walking me through what you did.

I have created a couple of events but they do not work. I’m using Matomo on WordPress.


Can you check in the visits log if all information of your event has been well tracked?
Can you also check (and share) the HTTP tracking request when your event has been triggered?

Hi there,

I got the same issue. As you can see the event value is set up on the tag request but the report isn’t populated.
I’m using the tag manager, On-premise server. My value is set by DOM elem custom variable that I created on the tag manager.

Thanks for helping.

Hi @nicointerstis
Event value must be numeric. Events gets 3 string parameters (Category [Mandatory], Action [Mandatory], Label [Optional]) and 1 numeric param (Value [Optional]). This last allow the calculation of sums, averages, etc.
If you need a 4th string information, you can provide a custom dimension:


Hi @heurteph-ei I understand what you mentioned, but the article on Event tracking did not mention this clearly that it has to be a numerical value, and hence I am here :grinning: (Article: https://matomo.org/faq/reports/implement-event-tracking-with-matomo/). Anyways, now I know, and I’ll be more cautious while setting up tags going forward :slight_smile:

@rohitsgulam You can follow this article, it’s quite straightforward, and almost same as Google Tag Manager.
Article: https://matomo.org/faq/reports/implement-event-tracking-with-matomo/