Error widget Feedburner Statistics

Hello,

I have Piwik 1.3 and
In my account (super user) I get this error from my feedburner:

Warning: SimpleXMLElement::__construct() [simplexmlelement.–construct]: Entity: line 18: parser error : Opening and ending tag mismatch: meta line 2 and head in /home/director/public_html/Piwik/plugins/ExampleFeedburner/ExampleFeedburner.php on line 112

Backtrace -->
#0 Piwik_ErrorHandler(2, SimpleXMLElement::__construct() [simplexmlelement.–construct]: Entity: line 18: parser error : Opening and ending tag mismatch: meta line 2 and head, /home/director/public_html/Piwik/plugins/ExampleFeedburner/ExampleFeedburner.php, 112, Array ([uri] => Directory WebSites,[yesterday] => Piwik_Date Object ([] => 1303185130,[] => UTC),[beforeYesterday] => Piwik_Date Object ([] => 1303098730,[] => UTC),[url] => https://feedburner.google.com/api/awareness/1.0/GetFeedData?uri=Directory WebSites&dates=2011-04-18,2011-04-19,[data] => 400 Bad Request

Google
Error

Bad Request

Your client has issued a malformed or illegal request.

)) called at [(null):0]#1 SimpleXMLElement->__construct(400 Bad Request
Google
Error

Bad Request

Your client has issued a malformed or illegal request.

) called at [/home/director/public_html/Piwik/plugins/ExampleFeedburner/ExampleFeedburner.php:112]#2 Piwik_ExampleFeedburner_Controller->getFeedData(Directory WebSites) called at [/home/director/public_html/Piwik/plugins/ExampleFeedburner/ExampleFeedburner.php:82]#3 Piwik_ExampleFeedburner_Controller->feedburner() called at [(null):0]#4 call_user_func_array(Array ([0] => Piwik_ExampleFeedburner_Controller Object ([] => ExampleFeedburner,[] => 2011-04-20,[] => Piwik_Date Object ([] => 1303307530,[] => UTC),[] => 1,[] => Piwik_Site Object ([] => 1)),[1] => feedburner), Array ()) called at [/home/director/public_html/Piwik/core/FrontController.php:127]#5 Piwik_FrontController->dispatch() called at [/home/director/public_html/Piwik/index.php:58]

Regards,
Razvan

Thanks, I’ve fixed this in trunk. see http://dev.piwik.org/trac/changeset/4528

But your problem is that your feed name “Directory WebSites” doesn’t exist. Try it without the space, i.e., “DirectoryWebSites”.

Hello, Anthon

Done!
Now works.
Thank you very much.

Best regards,
Razvan

I also experienced the same problem thanks for the help

same problem piwik 1.9 :frowning:

Actually, Google shut down the Feedburner API just this past weekend (on Oct 20, to be exact), so no one’s Feedburner widgets or plugins are going to work anymore.

See:

http://www.feedblitz.com/feedburner-shut-down-the-facts-and-tales-from-the-front-line/

and of course, the epitaph: https://developers.google.com/feedburner/