Error while archive.php tries to generate monthly report


#1

I upgraded to 2.2 fast – and some days later (at the end of april) the problems begins: The daily and weekly report works without any problems, but no data for the month. CoreConsole says (after about 8 minutes working after the daily/weekly reports, which only last 11.4 seconds for monday and the few hours of tuesday) - even after upgrading to 2.2.1 and trying again today:

INFO CoreConsole[2014-05-06 08:24:20] [10411] ERROR: Got invalid response from API request: https://www.___.de/piwik/index.php?module=API&method=API.get&idSite=1&period=month&date=last9&format=php&token_auth=d046e15ee65d739356fadd03932cbaa8&trigger=archivephp. The response was empty. This usually means a server error. This solution to this error is generally to increase the value of ‘memory_limit’ in your php.ini file. Please check your Web server Error Log file for more details.

Increasing memory does not help. In syslog I found:
kernel: [6384318.127657] php5[17858]: segfault at 7f2ee5c68e68 ip 00000000006bddfd sp 00007fff7e3216f0 error 4 in php5[400000+6f4000]

I use pure Debian 7.5 (amd64).

Any idea?


#2

Did you up the memory in php.ini? Check teh mem syntax to ensure its right. Also a couple links with similar issues maybe a hint in one of them?

http://forum.piwik.org/read.php?2,113069


(Matthieu Aubry) #3

Maybe try upgrade to latest PHP version as segmentation fault is usually a bug in core PHP or an extension


#4

With 2.2.2 it’s still the same: error (segmentation fault). So I’ll hope it’ll work again by chance with a further version of Piwik. Cause with 2.1 it works too :wink:

(Upgrading to latest php is no option for me – to much work and maybe problems with other software / php modules which work fine now as Debian delivers them. And as long as daily reporting works with piwik I prefer to live without monthly reports than to have the work with upgrading PHP.)


(Matthieu Aubry) #5

which php version are you using?


#6

@matt

The error occurred with the php version shipped with Debian Wheezy 7.5 (5.4.4-14+deb7u9).

Today I upgraded to php 5.4.28 via the debian-packages provided by dotdeb.org cause every php-module I needed is provided by dotdeb.org and so it was really easy. For today I only upgraded php, not mysql (I thought: do not change too much :wink:
And now piwik archiving works again :))) So it really was some kind of bug in php which is not solved in debian stable.