Error while adding a new plugin


(khouloud) #1

I want to add a new plugin. I follow the instruction provided here Add a new plugin
but when I write this command : php composer.phar install I get those errors :

[quote="Your requirements could not be resolved to an installable set of packages.

Problem 1
- Installation request for guzzle/guzzle v3.9.2 -> satisfiable by guzzle/guzzle[v3.9.2].
- guzzle/guzzle v3.9.2 requires ext-curl * -> the requested PHP extension curl is missing from your system.
Problem 2
- guzzle/guzzle v3.9.2 requires ext-curl * -> the requested PHP extension curl is missing from your system.
- aws/aws-sdk-php 2.7.1 requires guzzle/guzzle ~3.7 -> satisfiable by guzzle/guzzle[v3.9.2].
- Installation request for aws/aws-sdk-php 2.7.1 -> satisfiable by aws/aws-sdk-php[2.7.1]."]

[/quote]

Please Help


(Matthieu Aubry) #2

hi there

please install CURL on your system, eg. sudo apt-get install php5-curl


(khouloud) #3

Done and problem resolved

Thank you :slight_smile: