Error when loading report (v2.01)


#1

Just after implementing the new version, I tried an annual report exactly like the other times. Then, trying to load the pdf file, I got the error message below. The previously stored pdf reports can be normally opened, but this last one no:

There is an error. Please report the message (Piwik 2.0.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: fopen(/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/tmp/tcpdf/__tcpdf_imgmask_alpha_20ab86fc8a02d2a7c0d5c4828f3b8c27): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/libs/tcpdf/include/tcpdf_images.php on line 238

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [:]
#1 fopen(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/libs/tcpdf/include/tcpdf_images.php:238]
#2 TCPDF_IMAGES::_parsepng(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/libs/tcpdf/tcpdf.php:6967]
#3 TCPDF->Image(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/libs/tcpdf/tcpdf.php:6944]
#4 TCPDF->Image(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/core/ReportRenderer/Pdf.php:385]
#5 Piwik\ReportRenderer\Pdf->paintReportTable(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/core/ReportRenderer/Pdf.php:318]
#6 Piwik\ReportRenderer\Pdf->renderReport(…) called at [:]
#7 array_walk(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/plugins/ScheduledReports/API.php:444]
#8 Piwik\Plugins\ScheduledReports\API->generateReport(…) called at [:]
#9 call_user_func_array(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/core/API/Proxy.php:212]
#10 Piwik\API\Proxy->call(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/core/API/Request.php:220]
#11 Piwik\API\Request->process(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/plugins/API/Controller.php:34]
#12 Piwik\Plugins\API\Controller->index(…) called at [:]
#13 call_user_func_array(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/core/FrontController.php:117]
#14 Piwik\FrontController->dispatch(…) called at [/var/www/vhosts/piedagile.free-h.net/httpdocs/piwik/index.php:71]


(Matthieu Aubry) #2

thanks for the report, I created a ticket at Warning: fopen(/httpdocs/piwik/tmp/tcpdf/__tcpdf_imgmask_alpha_.... failed to open stream · Issue #4411 · matomo-org/matomo · GitHub


#3

same with v2.02.
However the HTML reporting is OK, the problem is only with PDF.B).
I saw you fixed it for 2.03.
Happy new year!


(Matthieu Aubry) #4

I haven’t fixed it yet actually: Error when downloading pdf-report · Issue #4404 · matomo-org/matomo · GitHub

I’m still not able to reproduce the problem. Could you PM me the FTP access to your piwik + URL + login/pwd + link to this forum URL?
I will take a look and try to fix… thanks


(Matthieu Aubry) #5

please try this fix: Refs #4404 Error when downloading pdf-report · matomo-org/matomo@566c63a · GitHub

do you still see some errors? which ones?