Error Piwik_Db_Schema_Myisam' not found after update


#1

First of all: Thank’s for this great piece of software!

However, I get an error after automatic update:


(Matthieu Aubry) #2

Please upload the file again, you can get it from SVN http://dev.piwik.org/svn/trunk/core/Db/Schema/


#3

I found out that it was an issue with APC.


#4

@matt: thank you, but this did not work.


(Chris Croome) #5

Hi

I have the same problem as this after upgrading to the latest Piwik 1.7.1.

I didn’t realise that Innodb was not supported and a few weeks ago the MySQL database was converted from MyISAM to INNODB, however I have now converted it back but I still have this error:

[quote=“Fatal error: Class ‘Piwik_Db_Schema_Myisam’ not found in /web/stats.transitionnetwork.org/piwik/core/Db/Schema.php on line 139”][/quote]

I did want to raise this as a bug on Trac, however I did a password recovery on http://dev.piwik.org/trac but this results in a redirect loop which then prevents one accessing Trac, so I can’t. I tried deleting the Trac cookies and also tried in Chrome (which has a better error message than Firefox):

[quote=“The webpage at http://dev.piwik.org/trac/prefs/account has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.”]

My concern is that if issue is not a ticket then nobody is going to notice it…?

I’m not sure what to try next…

Chris


#6

It worked for me when I removed APC. Don’t ask why, I don’t know.


(Chris Croome) #7

How do you “remove APC”?

Sorry I don’t know what APC is…


(Chris Croome) #8

matt’s suggestion above didn’t solve the prolem.

I have tried clearing the APC opcode cache and restarting apache and this didn’t change anything.

I have just tried running the cron task, this generates the following error:


Starting Piwik reports archiving...


Archiving period = day for idsite = 1...
PHP Fatal error:  Call to undefined method Piwik_Config::getInstance() in /web/stats.transitionnetwork.org/piwi
/Schema/Myisam.php on line 437

Fatal error: Call to undefined method Piwik_Config::getInstance() in /web/stats.transitionnetwork.org/piwik/cor
ma/Myisam.php on line 437

Before I updated the Myisam.php there wasn’t this error.

I then switched back to the 1.7.1 Myisam.php and the cron task runs without errors.


#9

Clearing the cache had no effect for me too. I had to remove APC completely and reinstall it. After that, everything was okay.


(Chris Croome) #10

[quote=HurlyBurly]
Clearing the cache had no effect for me too. I had to remove APC completely and reinstall it. After that, everything was okay.[/quote]

Wow, that worked for me as well!

This step really shouldn’t be needed should it…!


(Chris Croome) #11

I take that back, the dashboad loaded OK once but now it’s back to displaying the error the same as in the screenshot above :frowning:


(Chris Croome) #12

I have created a ticket for the trac password reset bug #3048 Password recovery for dev.piwik.org/trac results in a redirect loop · Issue #3048 · matomo-org/matomo · GitHub

And one for this issue #3049 Investigation: Fatal error: Class 'Piwik_Db_Schema_Myisam' not found in core/Db/Schema.php on line 139 · Issue #3049 · matomo-org/matomo · GitHub

Best follow this matter up via trac.


(Chris Croome) #13

The trac ticket #3049 has been closed with no suggestions about how to debug or fix this problem and I don’t have permissions to reopen it:


(vipsoft) #14

In cc’s case, the problem was apc settings. Disabling apc.include_once_override and setting apc.mmap_file_mask = /dev/zero did the trick.

In HurlyBurly’s case, I’m guessing apc.stat is off. As a workaround, please turn apc_stat on. (This has some performance impact on the web server, but will be less problematic for the next upgrade.) We do have a fix in the next release to clear the cache after overwriting the files from the new release. Of course, this won’t be apparent until the next-next update.