Error on Ecommerce log


#1

I am getting this error when trying to view “Ecommerce & Goals” -> "Ecommerce Log"
The machine is ubuntu 14.04(from Piwik Cloud Hosting, Deploy Piwik) and piwik is at version 2.9.1 (upgrade from 2.8.3 to 2.9.0 to 2.9.1).
It happens only for one of my sites, could it be that my javascript tracking code is used wrong ? maybe I am logging an event with an array instead of string ?

Also, Deleted emptied the tmp folder.

Notice:Array to string conversion in /opt/bitnami/apps/piwik/htdocs/tmp/templates_c/39/82/c2ce34e9baf5b19c28db4cfecf5d61f9960e74aed1849393cd50f8411d39.php on line 87

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/opt/bitnami/apps/piwik/htdocs/tmp/templates_c/39/82/c2ce34e9baf5b19c28db4cfecf5d61f9960e74aed1849393cd50f8411d39.php:87]
#1 __TwigTemplate_3982c2ce34e9baf5b19c28db4cfecf5d61f9960e74aed1849393cd50f8411d39->doDisplay(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:279]
#2 Twig_Template->displayWithErrorHandling(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:253]
#3 Twig_Template->display(…) called at [/opt/bitnami/apps/piwik/htdocs/tmp/templates_c/52/d8/edc963c50aafded2e03615e13b4f3f5ce748248e44f1ba12e382227fc39a.php:138]
#4 __TwigTemplate_52d8edc963c50aafded2e03615e13b4f3f5ce748248e44f1ba12e382227fc39a->doDisplay(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:279]
#5 Twig_Template->displayWithErrorHandling(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:253]
#6 Twig_Template->display(…) called at [/opt/bitnami/apps/piwik/htdocs/tmp/templates_c/3e/46/0198ca454371f5281a7ac692734364773f7e40859ae08d34f7fbfe6bb4dd.php:115]
#7 __TwigTemplate_3e460198ca454371f5281a7ac692734364773f7e40859ae08d34f7fbfe6bb4dd->doDisplay(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:279]
#8 Twig_Template->displayWithErrorHandling(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:253]
#9 Twig_Template->display(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Template.php:264]
#10 Twig_Template->render(…) called at [/opt/bitnami/apps/piwik/htdocs/vendor/twig/twig/lib/Twig/Environment.php:292]
#11 Twig_Environment->render(…) called at [/opt/bitnami/apps/piwik/htdocs/core/View.php:259]
#12 Piwik\View->renderTwigTemplate(…) called at [/opt/bitnami/apps/piwik/htdocs/core/View.php:253]
#13 Piwik\View->render(…) called at [/opt/bitnami/apps/piwik/htdocs/core/Plugin/ViewDataTable.php:415]
#14 Piwik\Plugin\ViewDataTable->render(…) called at [/opt/bitnami/apps/piwik/htdocs/core/Plugin/Report.php:304]
#15 Piwik\Plugin\Report->render(…) called at [/opt/bitnami/apps/piwik/htdocs/core/Plugin/Controller.php:329]
#16 Piwik\Plugin\Controller->renderReport(…) called at [/opt/bitnami/apps/piwik/htdocs/plugins/Live/Controller.php:70]
#17 Piwik\Plugins\Live\Controller->getVisitorLog(…) called at [:]
#18 call_user_func_array(…) called at [/opt/bitnami/apps/piwik/htdocs/core/FrontController.php:582]
#19 Piwik\FrontController->doDispatch(…) called at [/opt/bitnami/apps/piwik/htdocs/core/FrontController.php:96]
#20 Piwik\FrontController->dispatch(…) called at [/opt/bitnami/apps/piwik/htdocs/plugins/Goals/Controller.php:109]
#21 Piwik\Plugins\Goals\Controller->getEcommerceLog(…) called at [:]
#22 call_user_func_array(…) called at [/opt/bitnami/apps/piwik/htdocs/core/FrontController.php:582]
#23 Piwik\FrontController->doDispatch(…) called at [/opt/bitnami/apps/piwik/htdocs/core/FrontController.php:96]
#24 Piwik\FrontController->dispatch(…) called at [/opt/bitnami/apps/piwik/htdocs/core/dispatch.php:36]
#25 require_once(…) called at [/opt/bitnami/apps/piwik/htdocs/index.php:46]


(Matthieu Aubry) #2

Hi there, I didn’t see this error before. If you have more information it would be great, do you get the error in ecommerce log for each day of the month?


#3

It’s inside the “ACTIONDETAILS” column.
The value is “Array”, that’s why I think somewhere I incorrectly used the javascript tracking code and sent array instead of string.
I only have for the specific site one day worth of data.

What else do you need ?


#4

Same problem here:


There is an error. Please report the message (Piwik 2.9.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

 Notice:Array to string conversion in /piwik/tmp/templates_c/06/e9/8d13f6b90910853526617a22da6eefba1c03ff46f16fda6987b440d9aa0c.php on line 87

Backtrace -->

 #0 Piwik\Error::errorHandler(...) called at [/piwik/tmp/templates_c/06/e9/8d13f6b90910853526617a22da6eefba1c03ff46f16fda6987b440d9aa0c.php:87]
 #1 __TwigTemplate_06e98d13f6b90910853526617a22da6eefba1c03ff46f16fda6987b440d9aa0c->doDisplay(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
 #2 Twig_Template->displayWithErrorHandling(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
 #3 Twig_Template->display(...) called at [/piwik/tmp/templates_c/74/36/7aa4f13776d81133be36fd2f1fe50896dacf55ad52275f4a7d1c86f28be1.php:138]
 #4 __TwigTemplate_74367aa4f13776d81133be36fd2f1fe50896dacf55ad52275f4a7d1c86f28be1->doDisplay(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
 #5 Twig_Template->displayWithErrorHandling(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
 #6 Twig_Template->display(...) called at [/piwik/tmp/templates_c/f5/9f/b463644af015dec0fb15b7ca0172d244cb0eb68d36ad4556dfe2a86f9e8a.php:115]
 #7 __TwigTemplate_f59fb463644af015dec0fb15b7ca0172d244cb0eb68d36ad4556dfe2a86f9e8a->doDisplay(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:279]
 #8 Twig_Template->displayWithErrorHandling(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:253]
 #9 Twig_Template->display(...) called at [/piwik/vendor/twig/twig/lib/Twig/Template.php:264]
 #10 Twig_Template->render(...) called at [/piwik/vendor/twig/twig/lib/Twig/Environment.php:292]
 #11 Twig_Environment->render(...) called at [/piwik/core/View.php:259]
 #12 Piwik\View->renderTwigTemplate(...) called at [/piwik/core/View.php:253]
 #13 Piwik\View->render(...) called at [/piwik/core/Plugin/ViewDataTable.php:415]
 #14 Piwik\Plugin\ViewDataTable->render(...) called at [/piwik/core/Plugin/Report.php:304]
 #15 Piwik\Plugin\Report->render(...) called at [/piwik/core/Plugin/Controller.php:329]
 #16 Piwik\Plugin\Controller->renderReport(...) called at [/piwik/plugins/Live/Controller.php:70]
 #17 Piwik\Plugins\Live\Controller->getVisitorLog(...) called at [:]
 #18 call_user_func_array(...) called at [/piwik/core/FrontController.php:582]
 #19 Piwik\FrontController->doDispatch(...) called at [/piwik/core/FrontController.php:96]
 #20 Piwik\FrontController->dispatch(...) called at [/piwik/plugins/Goals/Controller.php:109]
 #21 Piwik\Plugins\Goals\Controller->getEcommerceLog(...) called at [:]
 #22 call_user_func_array(...) called at [/piwik/core/FrontController.php:582]
 #23 Piwik\FrontController->doDispatch(...) called at [/piwik/core/FrontController.php:96]
 #24 Piwik\FrontController->dispatch(...) called at [/piwik/core/dispatch.php:36]
 #25 require_once(...) called at [/piwik/index.php:46]

I’ve tried deleting the tmp/ folder contents, but it keeps happening.


(Matthieu Aubry) #5

Thanks for the report, can you please create an issue in github: Issues · matomo-org/piwik · GitHub and post the link here? we’ll investigate


#6

Here it is: Ecommerce Log shows error when there are abandoned carts and no conversion yet · Issue #6713 · matomo-org/matomo · GitHub