Error messages at visitor profile -> location


(schelli) #1

I use piwik version 2.0.3.
When I call the visitor profile I get an error at the location part:
Message:
#0 Piwik\Error::errorHandler(…) called at [:]
#1 htmlspecialchars(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/vendor/twig/twig/lib/Twig/Extension/Core.php:968]
#2 twig_escape_filter(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/tmp/templates_c/0f/36/35bb8b69b122dcbf1fe04502d3328f4b2fbe73c1fd1c883eb022313d3b1d.php:351]
#3 __TwigTemplate_0f3635bb8b69b122dcbf1fe04502d3328f4b2fbe73c1fd1c883eb022313d3b1d->doDisplay(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/vendor/twig/twig/lib/Twig/Template.php:276]
#4 Twig_Template->displayWithErrorHandling(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/vendor/twig/twig/lib/Twig/Template.php:250]
#5 Twig_Template->display(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/vendor/twig/twig/lib/Twig/Template.php:261]
#6 Twig_Template->render(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/vendor/twig/twig/lib/Twig/Environment.php:292]
#7 Twig_Environment->render(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/core/View.php:253]
#8 Piwik\View->renderTwigTemplate(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/core/View.php:248]
#9 Piwik\View->render(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/plugins/Live/Controller.php:157]
#10 Piwik\Plugins\Live\Controller->getVisitorProfilePopup(…) called at [:]
#11 call_user_func_array(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/core/FrontController.php:117]
#12 Piwik\FrontController->dispatch(…) called at [/var/www/vhosts/xxxxxx/httpsdocs/piwik/index.php:62]

This is happen not at every visitor profile. I looks like it just affects visitor profiles with a long history.
[attachment 1529 piwik-error.jpg]

I’m not sure that my error messages are the same issue like here: http://dev.piwik.org/trac/ticket/4330


(schelli) #2

I’m not sure that my error messages are the same like here: http://dev.piwik.org/trac/ticket/4330


(Matthieu Aubry) #3

Thanks for the report! I think you are experiencing Lots of error Messages viewing old visits · Issue #4330 · matomo-org/matomo · GitHub

Can you try the proposed fix at: Lots of error Messages viewing old visits · Issue #4330 · matomo-org/matomo · GitHub
Does it help this bug?


(schelli) #4

I set the “charset = utf8”. Now the visitor profile is shown without error messages.
[attachment 1531 piwik-error-update.jpg]
But all “Umlaute” are now not correctly displayed.
For example: ü = ü