Error Messages after Update to 1.1.1 (and previous beta)


#1

Hello, after updating i get the following messages. I even looked them up, but cant find a proper method for fixing it.
Maybe anyone can help?


Warning: Missing argument 5 for Piwik_Menu_Abstract::add(), called in /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php on line 106 and defined in /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php on line 45 

Backtrace -->
#0 Piwik_ErrorHandler(2, Missing argument 5 for Piwik_Menu_Abstract::add(), called in /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php on line 106 and defined, /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php, 45, Array ([menuName] => General_Visitors,[subMenuName] => Maps Live!,[url] => Array ([module] => Maps,[action] => getLiveVisitorsMapMenu),[displayedForCurrentUser] => 1)) called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:45]#1 Piwik_Menu_Abstract->add(General_Visitors, Maps Live!, Array ([module] => Maps,[action] => getLiveVisitorsMapMenu), 1) called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:106]#2 Piwik_Menu_Abstract->applyEdits() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:36]#3 Piwik_Menu_Abstract->get() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Main.php:66]#4 Piwik_Menu_Main->get() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Main.php:89]#5 Piwik_GetMenu() called at [/is/htdocs/wpXYZ/www/******/piwik/plugins/CoreHome/Controller.php:57]#6 Piwik_CoreHome_Controller->getDefaultIndexView() called at [/is/htdocs/wpXYZ/www/******/piwik/plugins/CoreHome/Controller.php:89]#7 Piwik_CoreHome_Controller->index() called at [(null):0]#8 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => 2011-01-05,[] => Piwik_Date Object ([] => 1294185600,[] => UTC),[] => 1,[] => Piwik_Site Object ([] => 1)),[1] => index), Array ()) called at [/is/htdocs/wpXYZ/www/******/piwik/core/FrontController.php:125]#9 Piwik_FrontController->dispatch() called at [/is/htdocs/wpXYZ/www/******/piwik/index.php:60]

There is an error. Please report the message and full backtrace in the Piwik forums.
Notice: Undefined variable: order in /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php on line 52 
Backtrace -->
#0 Piwik_ErrorHandler(8, Undefined variable: order, /is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php, 52, Array ([menuName] => General_Visitors,[subMenuName] => Maps Live!,[url] => Array ([module] => Maps,[action] => getLiveVisitorsMapMenu),[displayedForCurrentUser] => 1)) called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:52]#1 Piwik_Menu_Abstract->add(General_Visitors, Maps Live!, Array ([module] => Maps,[action] => getLiveVisitorsMapMenu), 1) called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:106]#2 Piwik_Menu_Abstract->applyEdits() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Abstract.php:36]#3 Piwik_Menu_Abstract->get() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Main.php:66]#4 Piwik_Menu_Main->get() called at [/is/htdocs/wpXYZ/www/******/piwik/core/Menu/Main.php:89]#5 Piwik_GetMenu() called at [/is/htdocs/wpXYZ/www/******/piwik/plugins/CoreHome/Controller.php:57]#6 Piwik_CoreHome_Controller->getDefaultIndexView() called at [/is/htdocs/wpXYZ/www/******/piwik/plugins/CoreHome/Controller.php:89]#7 Piwik_CoreHome_Controller->index() called at [(null):0]#8 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => 2011-01-05,[] => Piwik_Date Object ([] => 1294185600,[] => UTC),[] => 1,[] => Piwik_Site Object ([] => 1)),[1] => index), Array ()) called at [/is/htdocs/wpXYZ/www/******/piwik/core/FrontController.php:125]#9 Piwik_FrontController->dispatch() called at [/is/htdocs/wpXYZ/www/******/piwik/index.php:60]

I see that theres a prblem with the MapsLive and Modul… I also have installed: GeoIP (Ticket #45) Plugin.

Thank you in common


(Matthieu Aubry) #2

Thanks for the report, please apply the following patch: http://dev.piwik.org/trac/changeset/3638 which should fix the bug