Error message


(Knut) #1

hallo,

ich sehe jetzt erst, dass es ein deutsches forum gibt, deswegen hier noch einmal mein anliegen:
die unten stehende meldung bekomme ich, habt ihr eine idee, was ich da machen kann?

gruß, knut

__
There is an error. Please report the message (Piwik 2.6.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/usr/share/GeoIP/) is not within the allowed path(s): (/var/www/sk10638/:/tmp) in /var/www/sk10638/html/cms/piwik/plugins/UserCountry/LocationProvider/GeoIp/Pecl.php on line 130

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [:]
#1 is_dir(…) called at [/var/www/sk10638/html/cms/piwik/plugins/UserCountry/LocationProvider/GeoIp/Pecl.php:130]
#2 Piwik\Plugins\UserCountry\LocationProvider\GeoIp\Pecl->isWorking(…) called at [/var/www/sk10638/html/cms/piwik/plugins/UserCountry/LocationProvider.php:223]
#3 Piwik\Plugins\UserCountry\LocationProvider::getAllProviderInfo(…) called at [/var/www/sk10638/html/cms/piwik/plugins/Installation/SystemCheck.php:282]
#4 Piwik\Plugins\Installation\SystemCheck::checkGeolocation(…) called at [/var/www/sk10638/html/cms/piwik/plugins/Installation/SystemCheck.php:275]
#5 Piwik\Plugins\Installation\SystemCheck::performAdminPageOnlySystemCheck(…) called at [/var/www/sk10638/html/cms/piwik/plugins/Installation/Controller.php:432]
#6 Piwik\Plugins\Installation\Controller->systemCheckPage(…) called at [:]
#7 call_user_func_array(…) called at [/var/www/sk10638/html/cms/piwik/core/FrontController.php:577]
#8 Piwik\FrontController->doDispatch(…) called at [/var/www/sk10638/html/cms/piwik/core/FrontController.php:86]
#9 Piwik\FrontController->dispatch(…) called at [/var/www/sk10638/html/cms/piwik/core/dispatch.php:34]
#10 require_once(…) called at [/var/www/sk10638/html/cms/piwik/index.php:46]


(Stefan Giehl) #2

Hast du bei der Standorterkennung geoIP Pecl ausgewählt? Das scheint wohl nicht korrekt zu funktionieren.
Versuch doch mal auf eine andere Methode zu wechseln.


(Knut) #3

hallo,

vielen dank.
das steht bei mir auf standard. aber ich habe gesehen, dass hier (anhang) ein “defekt” steht.

kann ich das beheben? wie?

gruß, knut


(Stefan Giehl) #4

Hm, wenn der nicht ausgewählt ist, sollte dieser eigentlich nicht verwendet werden und auch keine Fehler verursachen.

An welcher Stelle ist der Fehler denn aufgetreten?


(Knut) #5

hallo,

ich habe nun piwik vom ftp-server gelöscht und neu eingespielt.
es geht bis step 2 (alles grün) , dann kann ich die datenbank in step 3 nicht einrichten.
wenn ich alle einträge gemacht habe, geht es einfach wieder von vorn (step 1) los ohne meldung.
mache ich (bewusst) einen falschen eintrag in step 3 kommt eine fehlermeldung.

könnt ihr helfen?

gruß, knut


(Knut) #6

hallo,

ich komme einfach nicht weiter.
bei “datenbank-server” steht immer automatisch die nummer 127.0.0.1, da muss ich ja
normal localhost eintragen. aber auch localhost wird nicht genommen.

habt ihr eine idee?

gruß, knut