Error installing IntranetGeoIP plugin (without internet access)


#1

Hello,

I am trying to install IntranetGeoIP plugin on a server which does not have access to Internet.

I manually downloaded plugin archived and uncompressed all files in folder \IntranetGeoIP.

From there, when I browse Piwik admin page, I systematically got the same below error.

It appears it does try to access piwik.org to check for update (http://plugins.piwik.org/api/1.0/plugins/checkUpdates), which is not possible as my server cannot access Internet.

In order to solve the problem, I tried to make the following modification in global.ini.php
enable_auto_update = 0

But I am still getting same error each time I browse the page.


 Warning: file_get_contents[b](http://plugins.piwik.org/api/1.0/plugins/checkUpdates[/b]?plugins=%7B%22plugins%22%3A%5B%7B%22name%22%3A%22IntranetGeoIP%22%2C%22version%22%3A%222.0.1%22%7D%5D%7D): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden  in <...>\piwik\core\Http.php on line 408 

Backtrace -->

 #0 Piwik\Error::errorHandler(...) called at [:]
 #1 file_get_contents(...) called at [<...>\piwik\core\Http.php:408]
 #2 Piwik\Http::sendHttpRequestBy(...) called at [<...>\piwik\core\Http.php:94]
 #3 Piwik\Http::sendHttpRequest(...) called at [<...>\piwik\plugins\CorePluginsAdmin\MarketplaceApiClient.php:145]
 #4 Piwik\Plugins\CorePluginsAdmin\MarketplaceApiClient->fetch(...) called at [<...>\piwik\plugins\CorePluginsAdmin\MarketplaceApiClient.php:82]
 #5 Piwik\Plugins\CorePluginsAdmin\MarketplaceApiClient->checkUpdates(...) called at [<...>\piwik\plugins\CorePluginsAdmin\MarketplaceApiClient.php:98]
 #6 Piwik\Plugins\CorePluginsAdmin\MarketplaceApiClient->getInfoOfPluginsHavingUpdate(...) called at [<...>\piwik\plugins\CorePluginsAdmin\Marketplace.php:112]
 #7 Piwik\Plugins\CorePluginsAdmin\Marketplace->getPluginsHavingUpdate(...) called at [<...>\piwik\plugins\CorePluginsAdmin\Menu.php:32]
 #8 Piwik\Plugins\CorePluginsAdmin\Menu->configureAdminMenu(...) called at [<...>\piwik\core\Menu\MenuAdmin.php:139]
 #9 Piwik\Menu\MenuAdmin->getMenu(...) called at [<...>\piwik\core\Menu\MenuAdmin.php:153]
 #10 Piwik\Menu\MenuAdmin->getCurrentAdminMenuName(...) called at [<...>\piwik\core\Plugin\ControllerAdmin.php:192]
 #11 Piwik\Plugin\ControllerAdmin::setBasicVariablesAdminView(...) called at [<...>\piwik\core\Plugin\ControllerAdmin.php:87]
 #12 Piwik\Plugin\ControllerAdmin->setBasicVariablesView(...) called at [<...>\piwik\core\Plugin\Controller.php:288]
 #13 Piwik\Plugin\Controller->renderTemplate(...) called at [<...>\piwik\plugins\SitesManager\Controller.php:30]
 #14 Piwik\Plugins\SitesManager\Controller->index(...) called at [:]
 #15 call_user_func_array(...) called at [<...>\piwik\core\FrontController.php:582]
 #16 Piwik\FrontController->doDispatch(...) called at [<...>\piwik\core\FrontController.php:96]
 #17 Piwik\FrontController->dispatch(...) called at [<...>\piwik\core\dispatch.php:36]
 #18 require_once(...) called at [<...>\piwik\index.php:46]


#2

I just found the answer… I forgot to configure this option:
enable_marketplace = 0

It is explained here: How do I configure Piwik on a server without Internet? - Analytics Platform - Matomo

No more error :slight_smile: