Error installing 0.4.5 on Windows


(realloafer) #1

When I installing 0.4.5
I have quite sure I enabled the pdo_mysql extension.

However, during the second step called systemcheck always prompts I did not enable it, can not continue.

I can see the version information of pdo_mysql in the phpinfo.

But no matter how, 0.4.5 installation of the systemcheck is always prompted "Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.
On a Windows server you can add the following lines to your php.ini:

extension=php_mysqli.dll
extension=php_pdo.dll
extension=php_pdo_mysql.dll
".

After I downloaded 0.4.3,it installed well. Could you tell me what’s wrong?

OS:windows server 2008 r2,IIS 7.5,PHP 5.2.11,MYSQL 5.1.38


(vipsoft) #2

What do you get when you run this:

<?php
print_r(get_loaded_extensions());
?>

(mehmet) #3

I’m experiencing the exact same issue as well, and I can verify that both pdo and pdo_mysql is loaded with get_loaded_extensions(). Is there any place I can download 0.4.4 or 0.4.3 version? Thanks.


(vipsoft) #4

Are you both running IIS 7.5 on Win2008?


(mehmet) #5

The problem is caused by Piwik’s globr function. When it escapes the search string, escapeshellcmd is removing the backslashes in the path strings of Windows systems, therefore the base path passed to glob is not correct. So it’s unable to find the *.php files under Db folder, causing the error in the installation. Will submit patch in a few minutes.


(Karlsson) #6

Is there any place I can download 0.4.4 or 0.4.3 version?

try: http://builds.piwik.org/


(vipsoft) #7

Thanks mehmet. We fixed that yesterday … about an hour after we released 0.4.5. =P

http://dev.piwik.org/trac/changeset/1529


(realloafer) #8

i agree,i think 0.4.5 has some problem,i hope there will be a new version as soon as possible


(realloafer) #9

i love you guys,so great,so fast,thank you


(mehmet) #10

[quote=vipsoft @ Oct 23 2009, 04:09 PM]Thanks mehmet. We fixed that yesterday … about an hour after we released 0.4.5. =P

dev.piwik.org/trac/changeset/1529[/quote]

Ah, I see. Thanks for the reply!


(maykino) #11

[quote=vipsoft @ Oct 23 2009, 10:15 AM]What do you get when you run this:

<?php
print_r(get_loaded_extensions());
?>

[/quote]

Array ( [0] => libxml [1] => xml [2] => session [3] => pcre [4] => SimpleXML [5] => SPL [6] => standard [7] => Reflection [8] => filter [9] => date [10] => apache2handler [11] => ctype [12] => curl [13] => dom [14] => ftp [15] => gd [16] => gettext [17] => hash [18] => iconv [19] => imap [20] => json [21] => mbstring [22] => mcrypt [23] => mysql [24] => mysqli [25] => openssl [26] => PDO [27] => pdo_mysql [28] => pdo_sqlite [29] => SQLite [30] => tokenizer [31] => xmlreader [32] => xmlwriter [33] => xsl [34] => zlib [35] => ionCube Loader )


(micojoy) #12

style_emoticons/<#EMO_DIR#>/dry.gif

this my php.ini windows 2003

piwik:
http:////tj.1.cdn.hi.cn/index.php?action=systemCheck

Piwik requires either the mysqli extension or both the PDO and pdo_mysql extensions.
On a Windows server you can add the following lines to your php.ini:

extension=php_mysqli.dll
extension=php_pdo.dll
extension=php_pdo_mysql.dll

More information on: PHP PDO and MYSQLI.

phpinfo:
http:////tj.1.cdn.hi.cn/c/iProber.php?act=phpinfo

I’ve set the php.ini, but it does not take effect, I also restarted IIS, and even restart the server style_emoticons/<#EMO_DIR#>/huh.gif

Who can help me to find ways to see where the problem lies in the style_emoticons/<#EMO_DIR#>/rolleyes.gif


(micojoy) #13

To find a solution, and remove the core / piwik.php 1352 lines $sDir = escapeshellcmd($sDir);


(ggreaves) #14

The best option if you have an installation already, is to;

  1. go to rootdir\piwik\config\ and activate the config.ini.php file (remove the word sample from the filename)
  2. edit the adapter line to use either PDO_MYSQL or MYSQLI not both.