Error getting plugins from marketplace


#1

I installed Piwik 2.4.1, if I go to admin>settings>plugins>Install new plugins, I get the following error:
There was an error reading the response from the Marketplace: {“plugins”:[{“name”:“SecurityInfo”,“owner”:“piwik”. Please try again later.
Also find the attached file for the snapshot.
Can anyone please help me out with this error…

Later, I tried re-installing piwik but still it didn’t work. On searching came across this link: http://git.piwik.org/piwik.git/raw/b9654b61b2dd1cfeb5dbcbdaedd7ca4cb91bd12f/plugins/CorePluginsAdmin/MarketplaceApiClient.php and replaced the content of the file plugins/CorePluginsAdmin/MarketplaceApiClient.php then I could get to the marketplace but on intalling VisitorGenerator got error as follows: Abort pclzip.lib.php : Missing zlib extensions


#2

I could figure that out, following was what I did:

In files,
core/Unzip/Gzip.php
core/Unzip.php
libs/Archive_Tar/Tar.php
libs/PclZip/pclzip.lib.php

‘gzopen’ needs to be replaced by ‘gzopen64’ and the page refreshed in the browser.
This solved my problem.


(Lukas Winkler) #3

3 posts were split to a new topic: Request to marketplace fails


(Lukas Winkler) #4

A post was merged into an existing topic: Request to marketplace fails