Error container.php online 210


I have this error at the plugin, I currently disabled it.
In these days I have noticed a high consumption of the server resources.
Do you have any solution?
Thank you

Version of WordPress 6.3.2
Active theme: Kadence Child Theme of Kadence (version 1.1.40)
Current plugin: Matomo Analytics – Ethical Stats. Powerful Insights. (version 4.15.2)
PHP version 8.1.23 Error details

An error of e_compile_error was caused in line 210 of the file /home/xxxx/public_html/wp-content/plugins/matomo/app/vendor/php-dip-dc/src/container.php. Error message: declaration of \ container :: has ($ name) must compatible with psr \ container \ container interface :: has (string $ id): bool Log error file

Php Fatal Error: Declaration of \ Container :: Has ($ Name) Must Be Compatible With PSR \ Container \ Container Interface :: Has (String $ ID): Bool in/Home/XXXX/Public_html/WP-Content/Plugins/Matomo /App/vendor/php-di/php-di/src/container.php online 210


The problem has been for a few days, I have also opened a ticket on, but to date there has been no answer, other people also have problems.
How do I solve it?
Do you have a upgrade?
Thank you

Hi @Gresio64 Could you please confirm if you are using Matomo On-Premise or Matomo for WordPress?

Hi @Emerson_N
I use matomo for wordpress

Thanks for confirming. Base on the error you are getting, it seems like there is a plugin installed that is not compatible with Matomo. Could you please check this link if you have one of the plugins installed?

If there is none, can you please disable all of your plugins except Matomo. Then enable them one by one and let us know which plugin will cause the issue?

I had opened a ticket for 15 days on, and some colleagues had reported this incompatibility with your plugin.

In my case I use backwpup, it is currently deactivated and the statistics work

I also wrote to Backwpup to report the problem, they told me they are working on it to solve it.

With the old versions of Matomo, the problem did not exist, I hope it will be resolved soon to be able to reactivate backwpup and have the safety bk


1 Like

Hi again @Gresio64. We do hope so too. As of the moment, we can’t provide you a specific time frame on when it will be resolve but we expect that this will be fixed when Matomo for WordPress v5.0 is released (No time frame yet).

Hi @Emerson_N,

Ok, we await the new version, for now I have solved by deactivating the backup plugin.
I thank you for the answer