Error after update 2.2.0 update


#1

Hello,

This morning I was notified to update to 2.2.0 version. As usual I proceed to automatic update, and after the process is done, when I want to enter the dashboard I have this error:

But when I go into settings, all my sites seems to be there. Also I added a new one just to test, and I was able to add it.
Any hints please?


#2

Following some advices from FAQ I delete all files from tmp folder and I empty the browser cache, now I can access the sites, but the dashboard is empty, and even if I create a new one (or reset the default one) I can’t see any widget on the dashboard.


(Matthieu Aubry) #3

Do you see any Javascript error in your browser ?


#4

Do you have “mod_pagespeed” enabled? I had the same problem and disabling mod_pagespeed fixed that.

Currently, I have no time to check, which setting of mod_pagespeed is the problem, but I will look at that in the next days.

Best Regards,

Dirk


#5

No, I see no errors and I didn’t make any changes to configuration.
Finally it seems that it was a cache mess. I drop again the dashboard and after I login with a browser that I never used to browse piwik I was able to build again a new dashboard and now it is working.
My opinion is that 2.2.0 seems to be somehow slow comparing to previous, especially as the piwik installation is in my internal home network.


#6

Hi,

Today I upgraded again to 2.2.1 as suggested by piwik. Immediately after update, I have the same issue as in previous message(s), I solved in the same way, after this I checked and it is working but after some hours, when I want to check some visits, I was unable to login with (finally) this message:

Welcome!

Your Piwik configuration file appears to be misconfigured. You can either remove config/config.ini.php and resume installation, or correct the database connection settings.

SQLSTATE[HY000] [2002] An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full.

Refresh the page »
Somehow the installation started automatically.
I am totally lost. Any hints?


#7

What if you increase the php.ini memory setting?


#8

I will try, but as the error in April, even today I have not changed anything in the configuration file either before or after update.
Anyway I don’t understand why Piwik want to reinstall itself.


#9

I increased the memory in php.ini, and I restarted the server because it was in kind of nirvana state (I was able to remote con it, the services are ok, the resources as well, but the server itself was not even able to browse in Chrome or IE it’s own IIS sites). After restart it’s working well.
Strange issue…