Error after 2.0.3 upgrade


(Ping Central Pty. Ltd.) #1

Good morning,

I am getting the following error when I click on [Email Reports] after upgrading from 2.0.2 to 2.0.3


Variable "displayFormats" does not exist in "@ScheduledReports/reportParametersScheduledReports.twig" at line 85

Please help :slight_smile:

Thanks,
Adrian.


(Matthieu Aubry) #2

please try to reupload all files from the latest beta version at: Index of /


#3

Hello,

I’m having the same problem after Upgrading to 2.0.3.
I downloaded the current Beta of 2.0.4 (b4) but the problem stays the same.

Thanks for any help!


#4

what php version are you using?


#5

I’m using PHP 5.4.20-1 over Fast-CGI


#6

anything in the web server logs that can hellp identify the issue? after updating perhaps the fast cgi settings need to be updated do a search on here for settings or implementation tips


#7

Nothing in the error.log for piwik.
FastCGI config looks fine from what others posted as recommendation for piwik on the internet.
Updated my PHP to 5.4.24-1 but no change.

Piwik’s System change also says everything is fine. (Everything is ticked, memory limit is set to 1GB)
Using Apache 2.2.22 as Webserver under Debian Wheezy.

Before I updated today on version 2.0.2 I was able to create an email report and bot 2.0.3 and 2.0.4-b4 show this error:
Variable “displayFormats” does not exist in “@ScheduledReports/reportParametersScheduledReports.twig” at line 85

I took a look at the file: ./plugins/ScheduledReports/templates/reportParametersScheduledReports.twig
It just has 78 lines and theres no displayFormats in there.


#8

how about apache error logs anything there?


#9

found this topic

http://forum.piwik.org/read.php?2,105879

not sure if applicable but saw that some has usses with php 5.4 then moving up to 5.5.x helped maybe here could do as well?


#10

No nothing in the error logs. The log folder of Piwik is also empty :frowning:

This is about Zend opCache which I don’t use. I’m using APC as opcode cache, but already tried to clear cache or disable it.
Upgrading to PHP 5.5 is not that easy in my case since theres not only Piwik running on that server.


#11

mhh… instead of downloading piwik on the server, extracting and overriding files and then recovering config and permissions I now uploaded the plugin files for the reports manually and now it works.


(Ping Central Pty. Ltd.) #12

Do you mean you un-installed the plugin and re-installed it?


#13

No. First I updated manually directly on the server (since automatic update gives me an error about invalid zip file or so since th update to 2.0 came out. Someone on the forums here had the same problem, there it was an invalid url in the config file but mine was correct).
So I downloaded the .zip file from the command line, copied my config.inc.php, unpacked the zip file and override all files, then copying back the config file and reset the permissions.
Now I downloaded the .zip File on my PC and just uploaded the files for the plugin again over sftp/scp and that fixed the error for me.

Looked like if unzip was not able to override these files for some reason, but everything other I tested works.