Error 1.5.1


#1

I had problems upgrading from 1.4 to 1.5.1 so I did a clean install. I get the following error:

Backtrace -->
#0 Piwik_ErrorHandler(8, Undefined index: isCustomLogo, /home/capeinfo/public_html/piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php, 78, Array ([this] => Piwik_Smarty Object ([template_dir] => Array ([0] => /home/capeinfo/public_html/piwik/plugins,[1] => /home/capeinfo/public_html/piwik/themes/default,[2] => /home/capeinfo/public_html/piwik/themes),[compile_dir] => /home/capeinfo/public_html/piwik/tmp/templates_c,[config_dir] => configs,[plugins_dir] => Array ([0] => /home/capeinfo/public_html/piwik/core/SmartyPlugins,[1] => /home/capeinfo/public_html/piwik/libs/Smarty/plugins),[debugging] => ,[error_reporting] => 6143,[debug_tpl] => ,[debugging_ctrl] => NONE,[compile_check] => 1,[force_compile] => ,[caching] => 0,[cache_dir] => /home/capeinfo/public_html/piwik/tmp/cache,[cache_lifetime] => 3600,[cache_modified_check] => ,[php_handling] => 0,[security] => ,[secure_dir] => Array (),[security_settings] => Array ([PHP_HANDLING] => ,[IF_FUNCS] => Array ([0] => array,[1] => list,[2…EnglishAbout Piwik translationsአማርኛالعربيةБеларускаяБългарскиCatalàČeskyDanskDeutschΕλληνικάEnglishEspañolEesti keelEuskaraSuomiFrançaisGalegoעבריתMagyarBahasa IndonesiaÍslenskaItaliano日本語ქართული한국어LietuviųNorsk (bokmål)NederlandsNynorskPolskiPortuguês brasileiroPortuguêsRomânăРусскийSlovenskySlovenščinaShqipSrpskiSvenskaతెలుగుภาษาไทยTürkçeУкраїнська简体中文繁體中文,[_order] => 30,[_hasSubmenu] => )),[debugTrackVisitsInsidePiwikUI] => 0,[isSuperUser] => ,[linkTitle] => Open Source Analytics,[enableFrames] => 0,[forceSslLogin] => 0,[nonce] => d76adfd282deffed346f4075f580a054,[currentModule] => ,[userLogin] => ,[sites] => Array (),[url] => http://capeinfo.com/piwik/index.php,[token_auth] => ,[userHasSomeAdminAccess] => ,[userIsSuperUser] => ,[latest_version_available] => 1.5.1,[disableLink] => 0,[show_autocompleter] => ,[loginModule] => Login,[totalTimeGeneration] => 0.118,[totalNumberOfQueries] => 0),[_smarty_vars] => ,[_sections] => Array (),[_foreach] => Array (),[_tag_stack] => Array (),[_conf_obj] => ,[_config] => Array ([0] => Array ([vars] => Array (),[files] => Array ()),[1] => Array ([vars] => Array (),[files] => Array ())),[_smarty_md5] => f8d698aea36fcbead2b9d5359ffca76f,[_version] => 2.6.26,[_inclusion_depth] => -1,[_compile_id] => ,[_smarty_debug_id] => SMARTY_DEBUG,[_smarty_debug_info] => Array (),[_cache_info] => Array (),[_fi…#1 include(/home/capeinfo/public_html/piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php) called at [/home/capeinfo/public_html/piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(Array ([smarty_include_tpl_file] => Login/templates/header.tpl,[smarty_include_vars] => Array ())) called at [/home/capeinfo/public_html/piwik/tmp/templates_c/%%F1^F18^F188CAAF%%login.tpl.php:6]#3 include(/home/capeinfo/public_html/piwik/tmp/templates_c/%%F1^F18^F188CAAF%%login.tpl.php) called at [/home/capeinfo/public_html/piwik/libs/Smarty/Smarty.class.php:1263]#4 Smarty->fetch(/home/capeinfo/public_html/piwik/plugins/Login/templates/login.tpl) called at [/home/capeinfo/public_html/piwik/core/View.php:136]#5 Piwik_View->render() called at [/home/capeinfo/public_html/piwik/plugins/Login/Controller.php:86]#6 Piwik_Login_Controller->login() called at [/home/capeinfo/public_html/piwik/plugins/Login/Controller.php:46]#7 Piwik_Login_Controller->index()#8 call_user_func_array(Array ([0] => Piwik_Login_Controller Object ([] => Login,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0)),[1] => index), Array ()) called at [/home/capeinfo/public_html/piwik/core/FrontController.php:127]#9 Piwik_FrontController->dispatch(Login, ) called at [/home/capeinfo/public_html/piwik/core/Controller.php:466]#10 Piwik_Controller->redirectToIndex(CoreHome, index, ) called at [/home/capeinfo/public_html/piwik/plugins/CoreHome/Controller.php:42]#11 Piwik_CoreHome_Controller->redirectToCoreHomeIndex()#12 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0)),[1] => redirectToCoreHomeIndex), Array ()) called at [/home/capeinfo/public_html/piwik/core/FrontController.php:127]#13 Piwik_FrontController->dispatch() called at [/home/capeinfo/public_html/piwik/index.php:58]

Open Source Analytics

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined index: isCustomLogo in /home/capeinfo/public_html/piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php on line 85

Backtrace -->
#0 Piwik_ErrorHandler(8, Undefined index: isCustomLogo, /home/capeinfo/public_html/piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php, 85, Array ([this] => Piwik_Smarty Object ([template_dir] => Array ([0] => /home/capeinfo/public_html/piwik/plugins,[1] => /home/capeinfo/public_html/piwik/themes/default,[2] => /home/capeinfo/public_html/piwik/themes),[compile_dir] => /home/capeinfo/public_html/piwik/tmp/templates_c,[config_dir] => configs,[plugins_dir] => Array ([0] => /home/capeinfo/public_html/piwik/core/SmartyPlugins,[1] => /home/capeinfo/public_html/piwik/libs/Smarty/plugins),[debugging] => ,[error_reporting] => 6143,[debug_tpl] => ,[debugging_ctrl] => NONE,[compile_check] => 1,[force_compile] => ,[caching] => 0,[cache_dir] => /home/capeinfo/public_html/piwik/tmp/cache,[cache_lifetime] => 3600,[cache_modified_check] => ,[php_handling] => 0,[security] => ,[secure_dir] => Array (),[security_settings] => Array ([PHP_HANDLING] => ,[IF_FUNCS] => Array ([0] => array,[1] => list,[2…EnglishAbout Piwik translationsአማርኛالعربيةБеларускаяБългарскиCatalàČeskyDanskDeutschΕλληνικάEnglishEspañolEesti keelEuskaraSuomiFrançaisGalegoעבריתMagyarBahasa IndonesiaÍslenskaItaliano日本語ქართული한국어LietuviųNorsk (bokmål)NederlandsNynorskPolskiPortuguês brasileiroPortuguêsRomânăРусскийSlovenskySlovenščinaShqipSrpskiSvenskaతెలుగుภาษาไทยTürkçeУкраїнська简体中文繁體中文,[_order] => 30,[_hasSubmenu] => )),[debugTrackVisitsInsidePiwikUI] => 0,[isSuperUser] => ,[linkTitle] => Open Source Analytics,[enableFrames] => 0,[forceSslLogin] => 0,[nonce] => d76adfd282deffed346f4075f580a054,[currentModule] => ,[userLogin] => ,[sites] => Array (),[url] => http://capeinfo.com/piwik/index.php,[token_auth] => ,[userHasSomeAdminAccess] => ,[userIsSuperUser] => ,[latest_version_available] => 1.5.1,[disableLink] => 0,[show_autocompleter] => ,[loginModule] => Login,[totalTimeGeneration] => 0.118,[totalNumberOfQueries] => 0),[_smarty_vars] => ,[_sections] => Array (),[_foreach] => Array (),[_tag_stack] => Array (),[_conf_obj] => ,[_config] => Array ([0] => Array ([vars] => Array (),[files] => Array ()),[1] => Array ([vars] => Array (),[files] => Array ())),[_smarty_md5] => f8d698aea36fcbead2b9d5359ffca76f,[_version] => 2.6.26,[_inclusion_depth] => -1,[_compile_id] => ,[_smarty_debug_id] => SMARTY_DEBUG,[_smarty_debug_info] => Array (),[_cache_info] => Array (),[_fi…#1 include(/home/capeinfo/public_html/piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php) called at [/home/capeinfo/public_html/piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(Array ([smarty_include_tpl_file] => Login/templates/header.tpl,[smarty_include_vars] => Array ())) called at [/home/capeinfo/public_html/piwik/tmp/templates_c/%%F1^F18^F188CAAF%%login.tpl.php:6]#3 include(/home/capeinfo/public_html/piwik/tmp/templates_c/%%F1^F18^F188CAAF%%login.tpl.php) called at [/home/capeinfo/public_html/piwik/libs/Smarty/Smarty.class.php:1263]#4 Smarty->fetch(/home/capeinfo/public_html/piwik/plugins/Login/templates/login.tpl) called at [/home/capeinfo/public_html/piwik/core/View.php:136]#5 Piwik_View->render() called at [/home/capeinfo/public_html/piwik/plugins/Login/Controller.php:86]#6 Piwik_Login_Controller->login() called at [/home/capeinfo/public_html/piwik/plugins/Login/Controller.php:46]#7 Piwik_Login_Controller->index()#8 call_user_func_array(Array ([0] => Piwik_Login_Controller Object ([] => Login,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0)),[1] => index), Array ()) called at [/home/capeinfo/public_html/piwik/core/FrontController.php:127]#9 Piwik_FrontController->dispatch(Login, ) called at [/home/capeinfo/public_html/piwik/core/Controller.php:466]#10 Piwik_Controller->redirectToIndex(CoreHome, index, ) called at [/home/capeinfo/public_html/piwik/plugins/CoreHome/Controller.php:42]#11 Piwik_CoreHome_Controller->redirectToCoreHomeIndex()#12 call_user_func_array(Array ([0] => Piwik_CoreHome_Controller Object ([] => CoreHome,[] => ,[] => ,[] => 0,[] => Piwik_Site Object ([] => 0)),[1] => redirectToCoreHomeIndex), Array ()) called at [/home/capeinfo/public_html/piwik/core/FrontController.php:127]#13 Piwik_FrontController->dispatch() called at [/home/capeinfo/public_html/piwik/index.php:58]


(Matthieu Aubry) #2

Delete all files in: /home/capeinfo/public_html/piwik/tmp/templates_c

the upgrade should do this automatically for you but maybe permissions problems prevented it to work


#3

Thank you. That fixed it.


#4

An error like that occour to me but the solution didn’t work, in settings chosing language or translation i get:

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice:
Undefined index: topMenu in /var/www/piwik/tmp/templates_c/%%A5^A51^A51D6D8B%%top_bar.tpl.php on line 8



Backtrace -->

#0 Piwik_ErrorHandler(…) called at [/var/www/piwik/tmp/templates_c/%%A5^A51^A51D6D8B%%top_bar.tpl.php:8]#1 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%38^383^383EA889%%header.tpl.php:55]#3 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#4 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%07^077^07747836%%languages.tpl.php:8]#5 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1263]#6 Smarty->fetch(…) called at [/var/www/piwik/core/View.php:138]#7 Piwik_View->render(…) called at [/var/www/piwik/plugins/TranslationsAdmin/Controller.php:388]#8 Piwik_TranslationsAdmin_Controller->languages(…) called at [:]#9 call_user_func_array(…) called at [/var/www/piwik/core/FrontController.php:136]#10 Piwik_FrontController->dispatch(…) called at [/var/www/piwik/index.php:53]


There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice:

Undefined index: logoHeader in /var/www/piwik/tmp/templates_c/%%C3^C3C^C3C9B2C7%%logo.tpl.php on line 9


Backtrace -->
#0 Piwik_ErrorHandler(…) called at [/var/www/piwik/tmp/templates_c/%%C3^C3C^C3C9B2C7%%logo.tpl.php:9]#1 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%38^383^383EA889%%header.tpl.php:63]#3 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#4 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%07^077^07747836%%languages.tpl.php:8]#5 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1263]#6 Smarty->fetch(…) called at [/var/www/piwik/core/View.php:138]#7 Piwik_View->render(…) called at [/var/www/piwik/plugins/TranslationsAdmin/Controller.php:388]#8 Piwik_TranslationsAdmin_Controller->languages(…) called at [:]#9 call_user_func_array(…) called at [/var/www/piwik/core/FrontController.php:136]#10 Piwik_FrontController->dispatch(…) called at [/var/www/piwik/index.php:53]


' alt="
There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice:
Undefined index: isCustomLogo in /var/www/piwik/tmp/templates_c/%%C3^C3C^C3C9B2C7%%logo.tpl.php on line 10



Backtrace -->

#0 Piwik_ErrorHandler(…) called at [/var/www/piwik/tmp/templates_c/%%C3^C3C^C3C9B2C7%%logo.tpl.php:10]#1 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%38^383^383EA889%%header.tpl.php:63]#3 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1869]#4 Smarty->_smarty_include(…) called at [/var/www/piwik/tmp/templates_c/%%07^077^07747836%%languages.tpl.php:8]#5 include(…) called at [/var/www/piwik/libs/Smarty/Smarty.class.php:1263]#6 Smarty->fetch(…) called at [/var/www/piwik/core/View.php:138]#7 Piwik_View->render(…) called at [/var/www/piwik/plugins/TranslationsAdmin/Controller.php:388]#8 Piwik_TranslationsAdmin_Controller->languages(…) called at [:]#9 call_user_func_array(…) called at [/var/www/piwik/core/FrontController.php:136]#10 Piwik_FrontController->dispatch(…) called at [/var/www/piwik/index.php:53]

Thank you