Erreur SLL avec PHP 5.6


#1

Bonjour

J’ai installé mon site sur le serveur A (PHP 5.6) et les stats sur le serveur B (PHP 5.5). Sur le site A, je rencontre un problème de lecture des statistiques.

Dans le fichier log, j’ai l’erreur suivante :

PHP Warning: file_get_contents(): Failed to enable crypto in /home/xxxxxx/xxxxxx/piwik.php on line 47
PHP Warning: file_get_contents(https://xxxxxx.xxxxxx.fr/piwik.js): failed to open stream: operation failed in /home/xxxxxx/xxxxxx/piwik.php on line 47

A noter que cela fonctionne si je règle le serveur avec PHP 5.5. Mais le but n’est pas de downgrader une version de PHP pour faire fonctionner Piwik. Sinon à quoi servirait les nouvelles versions de PHP. :smile:

Avez-vous déjà rencontré le problème ?

Hervé


#2

Précision : les stats sont installés sur un domaine en HTTPS.