Erreur de géolocalisation


#1

Bonjour,

Pour tester piwik, j’ai évidemment simuler une visite sur mon site.

Etant localisé à Genève, je m’attendais à trouver la première visite indiquée par piwik en Suisse.
Or celle-ci fut indiquée en France! :S

Serait-ce un bug ou simplement un problème de localisation n’ayant rien à voir avec piwik?
Est-ce que ce genre d’erreur est fréquent?
A quel point peut-on se fier aux indications de géolocalisation?

Bien à vous


#2

Je suis au Canada et lorsque la géolocalisation ne fonctionne pas cela donne France parce que Piwik va basculer vers la langue du navigateur et tout le monde sait qu’il n’y a que la France où on parle français. :wink:

Vérifie la section administrative de Piwik, il y a une section Géolocalisation où il sera indiqué quelle méthode tu utilises et si Piwik a détecté la BD “City”.

Il y a aussi dans /piwik/config/config.ini.php et il faut:

enable_language_to_country_guess = 0

Tout le reste est à Geo Locate your visitors - Analytics Platform - Matomo

Dali


#3

Super!
Merci beaucoup!


(Piwik) #4

Hello à tous !

je ne trouve cette ligne (enable_language_to_country_guess = 0 ) dans config.ini.php. j’ai ajouté le fichier GeoIPCity.dat à piwik (installation réussi de GeoIP php, mais malheuresement le géolocalisation ne trouve pas le bon pays !!

Sophie


#5

Sophie, la ligne n’y est pas par défaut.

Si tu regardes /piwik/config/global.ini.php , tu y veras l’ensemble des configurations par défaut. Il ne faut pas modifier ce fichier mais bel et bien recopier les lignes “intéressantes” dans ton config.ini.php qui lui ne sera jamais écrasé par une mise à jour.

Est-ce que c’est indiqué “Note: This GeoIP implementation has access to the following types of databases: City.” ou l’équivalent français dans Settings=>Geolocalisation ?

Est-ce que ton serveur est derrière un Proxy ? Moi j’ai dû ajouter ceci à mon config.ini.php :


proxy_client_headers[] = "HTTP_CLIENT_IP"
proxy_client_headers[] = "HTTP_X_FORWARDED_FOR"
proxy_host_headers[] = "HTTP_X_FORWARDED_HOST[Tracker]"

Dali