Email Reports to Outlook.com

Email Reports from Matomo will go to GMail, Yahoo!, and AOL, but not to Outlook Live. I can only assume this is a problem with how Microsoft has their webmail service configured. Email from the Matomo Forum (forum [at] matomo [dot] org) to Outlook Live goes to Junk by default, but I did get the confirmation email for Matomo Forum.

Is there a way to configure Matomo to send reports from a custom (real) email address instead of < noreply@domainname > ? I figure that might bypass any spam blocks set up for Outlook Live.

Hi,

You can change the From: Address Matomo uses as explained here:

1 Like

Thanks for that link. Unfortunately, I still cannot receive emails from Matomo to Outlook Live. I tried both PDF and HTML. I can receive PDF attachments from other senders though. Not sure why it is not working when there are no issues with other email providers. Is it possible that “outlook.com” is on a Matomo blacklist?

Can anyone else duplicate this issue? That would help me to determine whether it is a general bug or something to do with my specific configuration of either Matomo or Microsoft Outlook Live.

Hi,

There is no Matomo blacklist, but depending on your webserver setup it might be the other way round.

Do I understand it correctly that you use the mailserver of your webserver to send E-Mails and people can receive them but if sent to someone @outlook.com it never arrives?

In that case I’d strongly recommend you to double-check your mailserver set up. You at the very least need to have set up a reverse DNS entry, DKIM and SPF for even a slight chance that your mails won’t be dropped. But even then most E-Mail providers won’t accept mail from your server unless it is on no IP blacklist and doesn’t trigger any spam filter.
And outlook.com seems to be one of the strictest providers and I have heard of them marking perfectly fine mails as spam or not delivering them simply because it doesn’t come from an well established mail server.

I’d recommend you to use https://www.mail-tester.com/ to test if the mails sent by your Matomo instance are configured correctly.

1 Like

Thanks for that link. Emailing from “[at] nicolesharp [dot] net” actually has a better spam score than emailing from “[at] outlook [dot] com”, so everything seems to be configured as good or better than Microsoft. Though it looks like the only difference is that my Microsoft ID got a worse score because my Microsoft username ends in a number.

It took some time, but I got the rejected emails returned back to me. It looks like this could be a problem specific to Matomo installations on DreamHost Shared Website Hosting, so might have nothing to do with Matomo. Perhaps Microsoft is rejecting emails from DreamHost because DreamHost reuses IP addresses for multiple customers, so if another customer was abusing their shared hosting account to send spam, Microsoft could have flagged the IP address.

However, DreamHost support says that the issue could also be caused if Matomo is sending email from PHP instead of SMTP. So not sure if that is something that could be fixed within Matomo.

Otherwise, it is still a minor issue since I can receive emails from Matomo to any number of non-Outlook email addresses.


This is the mail system at host iad1-shared-relay1 [for DreamHost].

I’m sorry to have to inform you that your message could not be delivered to one or more recipients. It’s attached below.

If you are a current customer of DreamHost, please contact our technical support team…

If you are not a customer please use our contact form…

If you do so, please include this email in your support ticket. You can delete your own text from the attached returned message.

DreamHost Email Support

[Outlook email]: host [Outlook] said: 550 5.7.1.

Unfortunately, messages from [DreamHost] weren’t sent. Please contact your Internet service provider since part of their network is on our block list (S3140). You can also refer your provider to [Outlook Troubleshooting] (in reply to MAIL FROM command).

Action: failed
Status: 5.7.1
Diagnostic-Code: smtp; 550 5.7.1

Unfortunately, messages from [DreamHost] weren’t sent. Please contact your Internet service provider since part of their network is on our block list (S3140). You can also refer your provider to [Outlook Troubleshooting].

X-PHP-Originating-Script: 21861066:PHPMailer.php
Auto-Submitted: yes
MIME-Version: 1.0
Content-Type: multipart/mixed

Hi,

This is something you could look into.
Make sure you use Matomo 4 and then in the general settings enter the details to the SMTP server. Then Matomo will send the mail via SMTP instead of the PHP mail() function which might be more reliable.

Can you provide instructions on how to configure this for Matomo in General Settings?

This is the link provided to me by DreamHost:

Just go to the Matomo general settings, tick the checkbox and then enter the details you got from Dreamhost:

1 Like

Solved! Thanks for the help. I thought you meant the General Settings from config.ini.php but glad to see this can be set from the browser instead.

For anyone else experiencing the same issue on DreamHost, the settings to use are:

SMTP server address = smtp [dot] dreamhost [dot] com
SMTP port = 465
authentication method for SMTP = plain
SMTP username = example [at] dreamhosters [dot] com
SMTP password = YourEmailPassword
SMTP from address = example [at] dreamhosters [dot] com
SMTP from name = Your Name
SMTP encryption = SSL

1 Like