Email Reports NOW not Working - Memory Problems


#1

Hello,

Today after fixing some issue with a column on one of the Piwik tables finally could send an email report (last week).

Then tried changing on my Panel to a date range, 11/January to 30/January and showed me some memory limit errors, after trying with SEND EMAIL REPORT NOW.

After increasing the memory limit to 512 to PHP and uninstalling the ClamAV plugin on my VPS Cpanel server, I suddenly received the Report on my personal Gmail account. Only once.

After that, tried with several other date ranges so as the default configured one and allways get the same problem with the memory limit > 512 M.

I tried increasing the memory limit to 728, but it sends an email with the same similar memory problem, Resource: Virtual Memory Size … Exceeded: 695 > 512 (MB)

I am using the (default) Display Report tables, and also tried with the HTML format but allways receive the same error.

Is there any way to produce the report from shell script ?

Does the automatic process of sending emails use less memory footprint ?

I never had problems with version 1.6. And the information on the Reports has exactly the same format and volume of data.

Hope you can fix that very important issue.

Thanks,
Wilhelm.


#2

I tried rebooting the server, but the problems still remain the same.

I saw that today it could send several tests of 800k pdf attachments, and the last one was about 1MB (pdf) with Report from 11/Jan to 30/Jan.

It is very strange that it does not work now.


#3

I could solve the problem after deleting the “report” and creating a new one. On all websites you need to delete and create the same configuration again.

I first tried sending a simple report with a few options selected. After received the first email, completed the configuration.


#4

I thought the problems was resolved, but TODAY 21/02/2012 it happened again. No changes at server side … 512 M limit and 300 seconds to run, result was a lot of core.{proc_id} files at piwik installation path. Even with very short (less options selected) reports.

But after deleting the configuration and creating a new one, the process was fast.

I am trying with a fresh (complete) installation of version 1.7 but with same DB and config.ini.php file. The other (old) one was migrated from version 1.6 (original) to 1.7 with the easy-step one-click facility.

Should I try to migrate to a new DB and tables or is there something fixable to do with the actual DB ?


(Matthieu Aubry) #5

Processing “Custom date ranges” in piwik is expensive and has some memory issues as you can see.

It is recommended to setup the cron: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

And then send email for weeks/months/days, and it should be fast and work every time, but custom date ranges can be a problem… Also see Archiving Memory exhausted error - Archiving memory leaks · Issue #766 · matomo-org/matomo · GitHub