Email reports changing language


#1

I’ve got email reports set up to be emailed to me daily, using 1.7 beta, and all working well - except, one week after setting it up the reports mysteriously changed language.

Last time it turned to spanish, so I reinstalled (assuming it was something I’d done) and this time, they have changed into Slovakian.

Anyone got any idea’s on whats going on, why this would be happening or how I can make my reports go back into English?


#2

Yesterday it was fine, but today it is in Chinese.
Can someone who understands the code give me a hand to solve this?


#3

Today the report is in Italian…


(Matthieu Aubry) #4

Is it a new problem since 1.7 beta? was it working in 1.6 ?


#5

I’ve only ever used 1.7, so dont know if its a new feature


#6

Today, spanish!

Hola,
Encontrará el reporte de Diario…


#7

Hola,
Encontrará el reporte de Diario Yoursite como un archivo PDF adjunto.

Spanish again… Buenos Dias!


#8

مرحباً
انظر المرفقات رجاء لتحميل يومي التقارير حول

Today is Hebrew?


(Matthieu Aubry) #9

Can you please send me an email at matt at piwik with the bug report and link to this post? we can investigate


#10

I don’t know what you mean by the bug report, sorry.

Today, we have Thai!

สวัสดี
กรุณาหาในไฟล์แนบของคุณ แต่ละวัน รายงานสำหรับ


(Matthieu Aubry) #11

rendesr, sorry about that, we dont see the bug on our Piwik servers.

One question: did you setup a cron task such as : How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ?

If not, can you please try?

If using the cron fixes the “language” problem then we will still want to try to fix the bug, but at least I will know a bit where to look. Thanks


#12

Hey Matt, no I didn’t set up a cron like that, it was all done through the email reports screen in the admin section.
I will set the CRON up to archive my data, and see if that resolves the email report language issue!


(Matthieu Aubry) #13

Thanks for the bug report, other users reported it so I created a ticket Email reports sent with web cron are not sent in the user language · Issue #2950 · matomo-org/matomo · GitHub


#14

Thanks Matt, looking forward to the fix for this one!


(vipsoft) #15

Is this a Windows server?


#16

No, CentOS with Apache, PHP5


#17

Hi there,

I have the same problem and also think I know the source of it.
If a visitor e.g. from Russia visits your homepage and you use the iframe for opt-out, the iframe text wil be displayed related to the language settings of the visitor. this language change affects also the language of your emails.

As a salesman I´m not able to fix it, but I hope Matt can do it quickly, as these reports are sent to our clients also and you can not imagine how “high-quality” my sales approach is, if a client recently got a report in kyrrillic, thai or something else.

Always the first question: “Got our company website hacked?”

So I think it´s a mayor bug to fix!!!

cheers,

Thomas


(Matthieu Aubry) #18

This bug is fixed in 1.7.1 release