Einzelne Tage ohne Statistik


#1

Hallo,

im Piwik Plugin auf Wordpress aber auch auf dem Analytics Dashboard tauchen einzelne Tage mit sehr wenig bzw. 0 Traffic auf. Ich vermute das hängt mit den letzten Updates zusammen, denn es gab definitiv Traffic. In der Vergangenheit hat sich das nach ein paar Tagen von alleine gelöst und es wurden wieder korrekte Zahlen angezeigt. Dieses Mal löst sich das nicht von alleine. Gibt es eine Möglichkeit, die fehlenden Verdichtungen zu “aktualisieren”? Ich habe Zugriff auf Konsole und DB, habe mich aber bisher nicht mit dem Thema auseinandersetzen müssen. Sorry für diese Anfängerfrage und Danke für die Hilfe.

Liebe Grüße
pfm


(Stefan Giehl) #2

Das sollte mit der console von Piwik funktionieren.


./console core:archive --url="http://url.to/piwik" --force-date-range=2015-01-01,2015-02-01

URL und Zeitraum entsprechend anpassen und ggf. noch mit --force-idsites bestimmte Seiten archivieren lassen.

mit

./console --help core:archive

kannst du die alle möglichen Parameter ausgeben lassen


#3

Hallo,

danke für die Hilfe. Leider funktioniert das bei mir so nicht. Ich bekomme im Verzeichnis von Piwik mit dem ./console eine Fehlermeldung:


./console --help core:archive
X-Powered-By: PHP/4.4.9
Content-type: text/html

<br />
<b>Warning</b>:  Unexpected character in input:  '\' (ASCII=92) state=1 in <b>/homepages/.../.../../.../piwik/console</b> on line <b>18</b><br />

Die Punkte im Pfad sind nur Platzhalter (habe den richtigen Pfad entfernt). Habe das auch mit PHP5 ausgeführt mit selben Ergebnis.


(Stefan Giehl) #4

mit


php console --help core:archive

sollte sich das auch aufrufen lassen. Wenn du dann php5 zum aufrufen verwendest sollte es eigentlich funktionieren


#5

Leider funktioniert das auch nicht. Die Fehlermeldung bleibt die gleiche. Auch der Aufruf von nur


console

oder


php5 console

führt zum gleichen Fehler. Das ist sicher ein Anfängerfehler, aber leider kann ich das nicht ausführen. Ich stehe in dem /piwik Pfad, wenn ich das aufrufe und bin der SSH-User.


#6

Habe es nach langem ausprobieren hinbekommen.

PHP 5.x CLI Version in den Pfad eingetragen und Aufruf mit php haben in Kombination funktioniert.


#7

Das mit der Date-Range scheint aber komplett ignoriert zu werden. Er scheint nur die Statisitken des aktuellen Tages neu zu berechnen (bzw. skipped diese). Die Option Date-Range scheint nicht erkannt zu werden. Mache ich noch etwas falsch?


php console core:archive --url="[xxxxx/piwik]" --force-date-range=2015-05-25,2015-05-26

Ohne php als erstes Kommando wird PHP4 aufgerufen und damit kommt die Fehlermeldung oben.


(Stefan Giehl) #8

Das mit der Date-Range sollte schon berücksichtig werden.

Kopier doch mal die komplette Ausgabe des Skriptes hierein, dann schau ich mal drüber…


#9

Hallo Steve,

ich habe wie in einem anderen Thread beschrieben die jeweiligen Tabellen gelöscht und danach die Statistiken angeworfen. Jetzt geht das auch mit der Date-Range und es wird folgendermaßen ausgegeben:


INFO CoreConsole[2015-06-22 17:46:21] [667d6] Starting Piwik reports archiving...
INFO CoreConsole[2015-06-22 17:46:23] [667d6] Archived website id = 1, period = day, xxx visits in days included in: 2015-05-25,2015-05-26, Time elapsed: 2.433s
INFO CoreConsole[2015-06-22 17:46:24] [667d6] Archived website id = 1, period = week, yyy visits in weeks included in: 2015-05-25,2015-05-26, Time elapsed: 1.102s
INFO CoreConsole[2015-06-22 17:46:47] [667d6] Archived website id = 1, period = month, zzz visits in months included in: 2015-05-25,2015-05-26, Time elapsed: 22.820s
INFO CoreConsole[2015-06-22 17:46:59] [667d6] Archived website id = 1, period = year, abcdefg visits in years included in: 2015-05-25,2015-05-26, Time elapsed: 11.756s
INFO CoreConsole[2015-06-22 17:46:59] [667d6] Archived website id = 1, 4 API requests, Time elapsed: 38.113s [1/1 done]
INFO CoreConsole[2015-06-22 17:46:59] [667d6] Done archiving!

Diese Ausgabe habe ich vor dem Löschen der Tabellen nicht gesehen und die Zahlen wurden auch nicht neu berechnet. Scheint jetzt aber zu funktionieren. Aktuell habe ich keine “leeren” Tage mehr.