Einstellungen und Cronjob bei Hosteurope


#1

Hallo :slight_smile:

Piwiki macht einen interessanten Eindruck. Mit bis zu 5.000 Besuchern täglich (peak) ist wohl die cronjob Variante angebracht.

Im KIS bei Hosteurope habe ich einen angelegt der immer zur Minute 40 einer jeden Stunde startet. Was mir unklar ist, warum muss ich dann noch bei Piwiki “Die Verarbeitung der täglichen Berichte erfolgt maximal alle” die 3600 eingeben - ich denke die Daten werden jetzt stündliche vom Cronjob erstellt und in der oberen Option ist auch “Nein” ausgewählt?

Wie kann ich sehen wie lange der Cronjob läuft?


#2

Der Cronjob funktioniert irgendwie nicht. Habe versucht ihn ĂĽber putty zu starten, wirft jedoch als Fehlermeldung aus, dass fĂĽr das tmp Verzeichnis kein Schreibrecht bestehe. Das (und alle Unterorder sowie Dateien) haben jedoch bereits 777?!


Piwik couldn't write to some directories

Try to Execute the following commands on your server:
chmod 0777 /is/htdocs/wp1234566/www/piwik/tmp/templates_c
chmod 0777 /is/htdocs/wp1234566/www/piwik/tmp/cache
chmod 0777 /is/htdocs/wp1234566/www/piwik/tmp/assets

If this doesn't work, you can try to create the directories with your FTP software, and set the CHMOD to 0777 (with your FTP software, right click on the directories, permissions).


#3

Kann denn da keiner helfen? Habe schon mehrfach das Problem im englischen Forum finden können, jedoch keine Lösung :frowning:


#4

Wenn du bei der Option der Archivierung “Nein” ausgewählt hast, dann wird der Wert dadrunter ignoriert.

BezĂĽglich des Cronjobs bei Hosteurope solltest du sicherstellen, dass du absolute Pfade verwendest, falls das nicht schon der Fall ist. Zudem hat Hosteurope ein neues Rechtesystem, welches man per KIS aktivieren kann. Ich nutze dies, da ich mit dem alten System ab und zu mal genau solche Fehler hatte. Verzeichnis hat 777, jedoch Fehlermeldung beim Schreiben.


#5

Danke macringo. Was meinst Du mit absoluten Pfaden? Muss ich in der Cronjob Datei (/misc/cron/archive.sh) etwas ändern? Wenn ja, wo müssen da die Pfade eingetragen werden?

Die Fehlermeldung bei SSH AusfĂĽhrung vom Job zeigt ja den richtigen Pfad (/is/htdocs/wp1234566/www/piwik/tmp/). Also scheint der Job schon den Ordner richtig am Wickel zu haben.

Die Rechteverwaltung hat geholfen. Jetzt läuft es durch, meldet jedoch am Ende:


Archiving for idsite = 10 done!
Reports archiving finished.
---------------------------
Starting Scheduled tasks...

No data available
Finished Scheduled tasks.

Während des Durchlaufs scheinen jedoch keine Fehler aufzutreten.


#6

Doofe Frage. Gibt es denn ĂĽberhaupt Daten? :wink:

Soweit sieht das ja ganz gut aus. Offensichtlich lag es dann tatsächlich - mal wieder - an den Rechten. Der “spannende” Teil des Cronjobs findet in Zeile 98 und 99 statt. Kommentiere doch testweise Zeile 99 mal aus und setzte vor 98 ein echo. Dann kannst du zumindest prüfen, ob der Pfad korrekt ist. Müsste er aber eigentlich, weil er ja schon seine Site (10) erkannt hat.


#7

Daten gibt es bei 4k Besuchern im Schnitt eigentlich immer Neue :smiley:

Habe ich gemacht, da gibt er aus:


Starting Scheduled tasks...

/usr/local/bin/php5 -q /is/htdocs/wp1234566/www/piwik/misc/cron/../../index.php -- module=API&method=VisitsSummary.getVisits&idSite=10&period=year&date=last52&format=xml&token_auth=12345661234566123456612345661234566
Finished Scheduled tasks.

Der Job scheint jedoch zu funktionieren. Zumindest bereitet er die Daten fĂĽr die Webanzeige entsprechend auf :slight_smile: