Duplicate URL in Archiving Processing



I have the following script to import access log files into the database.

[piwik@piwik scripts]$ cat imp_single.sh

#set -x
num=ls -ltr | wc -l
#for HOUR in {01…23}
for HOUR in {00…23}
echo ${HOUR}/${DAY}/${MON}
echo ""
python /var/www/html/piwik/misc/log-analytics/import_logs.py --enable-http-errors --enable-http-errors --enable-http-redirects --exclude-path-from=/export/home/piwik/scripts/excludepaths.txt --url=https://stats.globalcollect.com/piwik/ --idsite=1 /export/home/piwik/upload/$MON/$DAY/na.gcsip.com_access2014${MON}${DAY}${HOUR};
sleep 10;
#sudo /var/www/html/piwik/misc/cron/archive.sh --url=https://stats.globalcollect.com;
sudo php /var/www/html/piwik/console core:archive --url=https//stats.globalcollect.com/piwik/ >> /export/home/piwik/piwik-archive.log

If you look at the --url= you will see that I have the full domain name of the site with no duplicates.

This morning when I tried to process a batch of files for a day that is missing data within Piwik, I received the following error.

ERROR CoreConsole[2014-11-04 08:16:04] [628a0] The Piwik URL http://https//stats.globalcollect.com/piwik/index.php does not seem to be pointing to a Piwik server. Response was ‘Got invalid response from API request: http://https//stats.globalcollect.com/piwik/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was ‘curl_exec: Couldn’t resolve host ‘https’. Hostname requested was: https’’.

Look at the URL is shows http://https//stat

why is there an http:// added to the start of my URL? This has to be something in the archive.php script of the archive process that is causing the URL to be incorrect.

Can anyone please help me with this.


(Matthieu Aubry) #2

Thanks for report. I think I fixed this bug few days ago. can you try with the latest beta: I would like to test early beta and RC releases, how do I enable automatic updates to use these development versions? - Analytics Platform - Matomo ?