Downloads ok as long as it's hierarchical

A weird one…

Piwik 1.12
PHP 5.3.13
Browser: Chrome 27 or FF 21

In Dashboard =>Downloads or Actions=>Downloads, I see files actually dowloaded but if I switch view to Make it flat I got an infamous “There is no data for this report.”

Same result for any website ID.

Any idea why ?


Hi Dali, I can’t reproduce this bug, but I remember there being a similar bug in the past. With the old bug there was an error that occurred which (for some reason) resulted in an empty datatable being displayed instead of the error. Can you check your webserver error logs (or piwik logs) for any clues? If there’s nothing there, would you mind sending me a private message with the hierarchical data that won’t be flattened?


I to have a similar problem my hierarchical reports don’t flatten I don’t see anything in the error.log

[attachment 1318 flat_error.png]

@capedfuzz to reproduce go to: Matomo Forums - June 5 – 15, 2013 - Web Analytics Reports - Matomo

Click “Make it flat”. you can see the bug.

Ok, I believe I’ve fixed this bug. Replace the /path/to/piwik/core/API/DataTableManipulator.php file with this one: and it should work. Let me know if it doesn’t.


It worked !

Let me add it worked on my clean 1.12 in Dashboard or Action=>Download on first try.

Thanks a lot,

Now if we could make table width a truncation-configuration setting instead of modyfying source at line #1111. Then download report would be almost perfect. :slight_smile:

Comming from TYPO3, I’m used to “never touch the Core”, use configurations instead. :wink:


there is another bug after bugfix in /path/to/piwik/core/API/DataTableManipulator.php.

Go to , select 2013-07-01 and the Actions > Page-Report, make it flat,
so there are lots of page URLs without Bounce Rate, without Exit Rate but with Avg. time on page = 0s. The correct values are displayed in the hierachical view.

I really appreciate any help you can provide.


Hi Agnes, sorry for the (it seems very) late reply. If you replace the /path/to/piwik/core/API/DataTableManipulator/Flattener.php file with this one, the bug should go away.