Doesn't report every connection


#1

Hi,
I am using Matomo v 3.9.1 and I 've discoverd, that not every visit is listed. I am using a wordpress ( v 4.9.4) website.
Into Admin / Appearance / GP Hook, I have copied and pasted the script into “before header”
I have checked " Execute PHP"
var u=“https://xxxxxxx.comt/”;
Where xxxxx.com got an IPV6 address.
I was thinking about, maybe , a problem between IPV4 & IPV6, but not sure…

There is no IPtables at all ( at least during the tests )

  1. How can I check if the communication between the website and Matomo is working fine ?
  2. Any idea of research ?

Thanks & regards,
Steve76


(Fabian Dellwing) #2

That are a bit less information to help you troubleshoot this problem. Are you using the PHP or JavaScript tracker? What exactly did you use as tracking code (replace your URL with example.com)? How it comes, that you think not every visit is tracked?


#3

Hi,

Sorry for the delay…

I am using PHP and my tracking code is

        <!-- Matomo -->

        <script type="text/javascript">

          var _paq = window._paq || [];

          /* tracker methods like "setCustomDimension" should be called
before "trackPageView" */

          _paq.push(["setDocumentTitle", document.domain + "/" +
document.title]);

          _paq.push(["setCookieDomain", "*.www.example.com"]);

          _paq.push(["setDomains",
["*.www..example.com","*.ca.example.com"]]);

          _paq.push(["enableCrossDomainLinking"]);

          _paq.push(['trackPageView']);

          _paq.push(['enableLinkTracking']);

          (function() {

           var u=;
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'),
s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true;
g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<!-- End Matomo Code -->

and this is placed into a wordpress website

I can see that some activity is seen, some are not seen.

For testing purpose, I’ve placed : var u=;
without any security. I thought that having a self signed
certificat might be the problem… So, at the moment, the port
1443 is redirect to the port 80 of the server

For instance, one day, I can see myself on the log, some other
days, didn’t work.

I also tried from my mobile phone… ( having another IP address ) and nothing is seen…

For testing purpose, there is no firewall at all ! and selinux is disabled…

 [root@analytics tmp]# iptables -L
 
         Chain INPUT (policy ACCEPT)
 
         target     prot opt source               destination
 
 
 
         Chain FORWARD (policy ACCEPT)
 
         target     prot opt source               destination
 
 
 
         Chain OUTPUT (policy ACCEPT)
 
         target     prot opt source               destination
 
         You have mail in /var/spool/mail/root

Is there a way to may some tests of connectivity ? I tried
telnet 1443 seems to connect… ( connection not refused )

Regards,