Does 4.71 fix the fatal sql error on upgrade using MySQL version 5.5?

This is the changelog text: “Note: We have released 4.7.1 shortly after 4.7.0 to address a small issue in our release process (we prematurely released several changes scheduled for 4.8.0) and to fix several small regressions.”

There are multiple posts in this forum about the fatal errors the db queries produce on MySQL 5.5. versions. I have some sharde hosted installations running on 5.5. Has it solved this issues for the people having this issue. I do not always have root access to change the config.

It should, as the fix:

is closed now and attached to the 4.7.1 Milestone…

Not quite, as far as I am concerned (running under MySQL 5.5).
Just tried to update and I’m getting a different error this time (I had the initial issue with 4.7.0):

/core/Updates/4.7.1-b1.php: Error trying to execute the migration ‘ALTER TABLE piwik_changes ADD UNIQUE KEY unique_plugin_version_title (plugin_name, version, title (100));’. The error was: SQLSTATE[HY000]: General error: 1089 Incorrect prefix key; the used key part isn’t a string, the used length is longer than the key part, or the storage engine doesn’t support unique prefix keys

Actually, table piwik_changes is now empty, without any record.
Table piwik_option still records ‘4.7.0’ as its version_core value.

Any advice?

I have just updated to 4.7.1 (using MySQL/MariaDB version 5.5) and it went without any problems. It looks like 4.7.1 fixed the queries.

I took the opportunity to upgrade to MySQL 5.7 (even though some here state it has no impact), and manually change the ‘version_core’ value to ‘4.7.1’.
This was enough to set things back to normal. I take this as pure magic, and that’s enough to me. :wink:
Thanks to the community. Happy analytics!

Just to be save, I’d recommend you to (now that you are on 5.7) change version_core back to 4.6.x that was before the update and let them run through once again (to make sure you didn’t skip a migration and will have issues one day in the future.

No luck. In doing so, I get that same 1089 error as before.

  • the piwik_option table now defines version_core as “4.7.0-b2”.
  • the piwik_changes table is empty, with plugin_name defined as varchar(60) and title defined as varchar(85).

Maybe something went wrong in my first update from 4.6.x to 4.7.0 which then prevents a smooth update to 4.7.1?

I’ve now reset the version_core value to “4.7.1” just to allow proper access to the data, which seems to be pouring in normally.