Docker MySQL/Piwik : SQLSTATE[HY000] [2054]

Hi team,
I have try to setup à Piwik service for my ghost blog.
I have some problem to connect Piwik with the database.

I have 2 docker containers, one with MySQL:8 and another one with Piwik:lastest.
When i’m going to setup Piwik i have some problem to connect him to the database.
I have an error after pick my credentials.

CONTAINER ID        IMAGE               COMMAND                  CREATED             STATUS              PORTS                  NAMES
86551548e835        piwik               "/ ap..."   21 minutes ago      Up 21 minutes>80/tcp   piwik
c54a0d7a2154        mysql:8             "docker-entrypoint..."   39 minutes ago      Up 39 minutes       3306/tcp               piwiksql

My Piwi is link to the MySQL container

Erreur lors de la tentative de connexion au serveur de base de données: SQLSTATE[HY000] [2054] Server sent charset unknown to the client. Please, report to the developers

Here an pics of the error :

My seup commands :

docker run --name piwiksql -e MYSQL_ROOT_PASSWORD=**************** -d mysql:8
docker run --name piwik -d -p 9000:80 --link piwiksql:db piwik

Thanks for you’re attention :slight_smile:

Hi, little up.
Any one have an idea ?
I have retry to day, alway did’nt work.

Can we force the UTF-8 setup ?
With something like that “mysql:db;dbname=piwik;charset=utf8”

Allways the same thing.
I have remove to day my docker image of piwik and try to repull the last version.
Same error.

If anyone have a solution i’m will be happy to take it :slight_smile:

Hi, try to use utf8mb4

Hi thanks for you’re attention.
I have connecte to my container piwiksql to setup the database with the following command :

`CREATE DATABASE piwik CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;`

mysql> show databases;
| Database           |
| information_schema |
| mysql              |
| performance_schema |
| piwik              |
| sys                |
5 rows in set (0.00 sec)

Allways the same charset problem :confused:
Same error message at piwik connection to db…

I have retry to day to setup Piwik 3.0.4.
Again the same error.

See u.

I have the same problem, did you resolve the issue?

Nop, i’m still waiting help from a dev…