Delete Old Logs Problem - 2.14.0-b2


#1

When try to save my settings. I get these errors:


WARNING: ****/plugins/PrivacyManager/LogDataPurger.php(58): Notice - Undefined variable: deleteLogsOlderThan - Piwik 2.14.0-b2 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)


WARNING: ****/plugins/PrivacyManager/LogDataPurger.php(56): Warning - Missing argument 2 for Piwik\Plugins\PrivacyManager\LogDataPurger::purgeData(), called in ****/plugins/PrivacyManager/Controller.php on line 172 and defined - Piwik 2.14.0-b2 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)


WARNING: ****/plugins/PrivacyManager/LogDataPurger.php(56): Warning - Missing argument 1 for Piwik\Plugins\PrivacyManager\LogDataPurger::purgeData(), called in ****/plugins/PrivacyManager/Controller.php on line 172 and defined - Piwik 2.14.0-b2 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)


(Matthieu Aubry) #2

Hi there

can you please try the latest beta? I can’t reproduce the issue, but if you still have issue with latest beta, let us know in: Issues · matomo-org/piwik · GitHub