Deactivate home-calling (connection to internet)


#1

Hello,
Is there a way to deactivate the feature i.e. avoid the connection to the internet which Matomo try to establish (marketplace etc.). In our infrastructure are this kind of home-calling not possible/not allowed and now the Matomo installation is extremely slow since Matomo try to call home all the time.


(Lukas Winkler) #2

Hi,

You can do this in the config:

UPDATE: Sorry, I didn’t read the linked pull request properly. Thanks to this all of these settings have been merged and completed into

enable_internet_features = 0

#3

Great! Thank you for the quick reply!


#4

Sadly the solution is not working.
Added the lines to cinfig.php

enable_marketplace = 0
enable_auto_update = 0
enable_update_communication = 0

don’t prevent Matomo to try the home call.
It’s still try to call: 185.31.40.177 (piwik.alwaysdata.net).
The problem is if we give Matomo a firewall permission: if the IP is changing, we need to change permission again and again.

EDIT: deactivating the marketplace plugin in the admin interface helped.


(Lukas Winkler) #5

Hi @ResponsibleUser,

Sorry, I didn’t read the linked pull request properly. Thanks to this all of these settings have been merged and completed into

enable_internet_features = 0

#6

Thank you!

This setting is working!

Just to your attention:
It may cause some problems with Heatmap-Recording. I’m really not sure, maybe this only appears in the system-check panel:

We couldn’t check if ‘https://xxxxxx/piwik/plugins/HeatmapSessionRecording/configs.php?idsite=xxxxx&trackerid=xxxx&url=http%3A%2F%2Ftest.test%2F’ is accessible because the internet connection is disabled on this Matomo.

However: the given URL is available in the browser!

Thank you again for your effort!


(Lukas Winkler) #7

Hi,

The Heatmap-Recording requires visitors to be able to visit https://matomo.example/piwik/plugins/HeatmapSessionRecording/configs.php. If your heatmaps are showing up fine, it’s pretty sure that this is working fine.

To detect cases where this doesn’t work, the system-check tries to request this URL.

As you have now disabled that Matomo fetches HTTP resources, this feature has also been disabled.

But if the configs.php is configured correctly for you (which it is if you can access it), you don’t need this automated check.