Datenbankfehler nach Update


#1

Ein paar Informationen vorweg: ich habe sehr wenig Kenntnisse, es aber geschafft, (vor vielleicht einem Jahr) Piwik zu installieren, nachdem ich Google Analytics nicht mehr wollte. Ein automatisches Update läuft nicht, weil irgendwelche Sicherheitseinstellungen meines Webhosters (host europe) das verhindern. Daher hatte ich bisher nur einmal manuell upgedated (auf 2.1.0) , was recht mühsam war, aber funktionierte.

Vor wenigen Tage habe ich ein erneutes manuelles Update veranstaltet (Download der aktuellen Version, entpacken auf meinem Rechner und upload der Dateien in die zuvor gelöschten Verzeichnisse. Das funktionierte soweit. Beim ersten Start fragte Piwik, ob die Datenbankenstruktur angepasst werden solle, was ich bejaht habe.

Daraufhin gab es eine Fehlermeldung, dass die Konfigurationsdatei nicht beschrieben werden könne (die ich nach dem Backup wieder hochgeladen hatte). Ich habe daraufhin in einem weiteren TAB die Berechtigung für die Konfig angepasst und das im Piwik-TAB bestätigt (glaubte ich zumindest). Die Anpassung der Datenbank ist aber offensichtlich nicht (einwandfrei) gelaufen, denn seither bekomme ich haufenweise Fehlermeldungen, die aber im Kern das Gleiche enthalten:
SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘log_link_visit_action.idaction_content_name’ in ‘where clause’

Kann ich hier etwas nachbessern?

Für Tipps wäre ich sehr dankbar, aber ich bitte vorbeugend um Nachsicht dafür, dass ich ggf. vieles nicht verstehe.

Edit: Ich habe noch einen Screenshot zur Illustration angehängt.


#2

Ich habe es jetzt geschafft, die richtige Datenbank ausfindig zu machen und das als fehlend reklamierte Feld einzufügen.
Da ich nicht mehr als nur den Feldnamen weiß, habe ich die weiteren Daten zum Feldformat auf Vorgabe stehenlassen.

Jetzt wird meine Piwik-Seite wieder ordentlich angezeigt. Ich hoffe nur, dass ich keinen neuen Fehler eingebaut habe.