Database inaccessible after upgrade from 2.10.0 to 2.11.0


(Marbot) #1

Both using the webinstaller to update as well as the classic method of updating make the database inaccessible SQLSTATE[42000] [1044] Access denied for user … when trying to update from 2.10.0 to 2.11.0. In both cases “config.ini.php” sits untouched at the right spot. I did not fiddle with the database at all so I am not sure where this is coming from. Since I now lost two of three instances (did not upgrade the latter) any help will be appreciated.

PHP 5.4.36, MySQL 5.5.41 on a Debian 7.8


(Marbot) #2

I tried to change host = “localhost” to host = “127.0.0.1” - nothing


(Marbot) #3

I appear not to be the only one facing this issue. There is also a thread in the German forum as well.


(Matthieu Aubry) #4

Hi there,

that’s very strange, I don’t think we changed anything in the database handling code that could create such issue. Can you maybe ask your webhost or check that the user really has access?

The user needs specific access which are detailed in: Piwik Requirements - Analytics Platform - Matomo


(Marbot) #5

Hi Matt, unfortunately this is not the issue. The db user has all privileges to that database except for grant. I have been using this database since 2009-06-26. I started out with piwik 0.4-something if I remember correctly. Never had such an issue. The password does not contain multibyte characters however has 23 chars. The user has 16 chars which is to my experience the max for MySQL so this should be fine too. Perhaps the new version now starts to cap the password at say 16 or so but this must be a new thing then. Piwik 2.10.0 worked nice until yesterday morning. I currently have no idea what to do. Cheers


(Marbot) #6

Just tried with a 5 digit user name and a 6 digit passwort. No change. :frowning:


(Marbot) #7

It was suggested in the German support forum that killing the tmp directory may perhaps help due to some escaping thing. No change however …


(Marbot) #8

So this is what has happened in the meantime. I killed all of piwik and uploaded the files to get a fresh start. Using the old configuration file again gave me SQLSTATE[42000] [1044] Access denied for user …, so I killed the configuartion file and tried an fresh install with 2.11.0. System check was all fluffy, I entered the credentials and I got: SQLSTATE[42000] [1044] Access denied for user … EOS. Then again I killed the code moved in the code for 2.10.0 added the old configuration file and everything is working allrighty. Access to the db is ok, tracking ok, paradise nearly regained except for not being able to use 2.11.0 This is pretty weird since this issue popped up not just for one instance but for two. Did not touch the third instance though but the outcome is pretty predictable for me.


(Matthieu Aubry) #9

Hi Marbot.

wow this is extremely strange! if you definitely can’t use 2.11.0 but can use 2.10.0 then it must be a code change that cause this bug. Can you create a bug report on : Issues · matomo-org/piwik · GitHub with this info? we’ll take a look, or hopefully someone else could report the same issue.


(Marbot) #10

Thanks for your advice. I just filed issue 7275. As a matter of fact another person reported this issue even before did 301 Moved Permanently Keeping fingers crossed


(Matthieu Aubry) #11

If you experience this issue please report it in the Gihtub issue at: SQLSTATE[42000] [1044] Access denied for user 'xyz'@'localhost' to database 'abc' · Issue #7275 · matomo-org/piwik · GitHub we need more users to help us reproduce and understand this bug! thanks