Dashboard not refreshing


(lalquier) #1

I noticed today that my dashboard widgets are stuck on yesterday’s stats (except for the sparklines of the Visits overview).

The menu bar under the Dashboard tab is also empty.

Changing browser or emptying the cache didn’t help.

I am using 1.1.2b1.


(lalquier) #2

This is getting weirder and weirder.

Depending when I reload my dashboard, I am getting stats from earlier today, stats from yesterday, empty stats and so on.

If I go to a particular tab (say Visitors), the refresh of widgets ends up refreshing the dashboard widgets in yet another configuration.

It looked like Piwik was working for a while after I applied the 1.1.2b1 patch, but since this morning, it looks stuck with this refresh problem.

Edit: Now I think of it, the only thing that changed since I installed the patch is that I attempted a refresh of the reports by deleting the two _archives tables for January 2011. The tables were apparently rebuilt but I have had this refresh problem since.

Edit 2: Another observation if it can help with troubleshooting.
When I go to the Visitor Log, the page turns up blank. But if I select today’s date in the calendar (which is already set to today at this point), the page reloads with actual visits displayed.


(Matthieu Aubry) #3

lalquier, send piwik URL + login/pwd + bug description and how to replicate at matt att piwik.org


(lalquier) #4

Once again, I wish I could do that but it is not possible since I am running Piwik on an Intranet.


(Matthieu Aubry) #5

check your apache error logs, and also try and setup auto archiving: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo