Custom Dimensions are not tracked properly


I have following problem with Custom Dimension.

I call something like:

_paq .push([ “setCustomDimension” , 1 , “val1” ]);

Custom Dimension with ID 1 was configured in Matomo Console.
I have tried to make many such requests, but only some of them come into statistic. Most of them were lost.
Even some days later I don’t see them.

In the same time I was tracking events:

_paq .push([ ‘trackEvent’ , ‘TopNews’ , ‘val1’ , ‘val2’ ]);

These requests I can see in statistics. 100% of them is inside.

Below you can see my Custom Dimension statistic. I did at this day probably 100 requests. Only 5 of them were tracked.
I tried different browser. Before each request this Custom Dimension was deleted.

What could be a problem?


This will track the event of category TopNews, action val1, name val2. There is no specific dimension there, except if a dimension has been defined previously in the script…
Also, the _paq .push([ “setCustomDimension” , 1 , “val1” ]); command will not send anything immediately to Matomo, it will just complete all further tracking with this dimension information…