curl_exec: couldn't connect to host

I’m hosting Piwik on a VPS server, it worked fine for a couple of weeks, but since yesterday I keep getting the error ‘curl_exec: couldn’t connect to host’ for the SEO Stats.

I didn’t change anything to my server, and I tried to ping some website, and all of them worked…
What can cause this error?

I got the same thing. I noticed it after I had Hostgator update my PHP from to 5.4


I didn’t do any update…
I only installed PECL GeoIP :slight_smile:

Same problem here…

VPS on Centos - was working ok yesterday morning, not done any updates or installed anything

Same problem on my site, no changes done the last weeks!

I seem to have the same little problem.
Everything works perfect, exept for the ‘SEO Ranking’ widget.

Nothing has changed in my Piwik configuration/installation for the last 3 or 4 weeks. No PHP version updates on the server. Nothing actually. So, I really don’t know how this is caused.

It would be nice to see this little issue resolved.

Same problem here. Godaddy Deluxe Shared Hosting. Godaddy said they went in and maxed out the memory limit in the php config file (I believe) . SEO Rankings was working fine until a few days ago. Any thoughts?

same problem here on domaingo servers…
no piwik updates or addons changed, no php changes.

Seems like we are all having the same error, I have this now too :S

me, too!

-> MajesticSEO API is down, I have contacted them to let them know and they will restore it.

Note: in Piwik 2.0, the SEO widget will display properly with “Zeros” instead of erroring (this was fixed in git since 1.12)

Thank you, matt…

Thanks Matt, all is back to normal now

Thanks Matt! That did the trick…

Thanks for the quick fix! (tu)